aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-02-21 20:43:35 +0100
committerFelix Fietkau <nbd@nbd.name>2017-02-21 20:43:40 +0100
commit0aa46bf76ab01fe1f64b0992fe2a8196c3b19d89 (patch)
treec943f5e759a04ad544b704b5bc3bcf260933db43 /package/Makefile
parentf66a0c93b3a49a1768efeab73553c6e8294b1443 (diff)
downloadupstream-0aa46bf76ab01fe1f64b0992fe2a8196c3b19d89.tar.gz
upstream-0aa46bf76ab01fe1f64b0992fe2a8196c3b19d89.tar.bz2
upstream-0aa46bf76ab01fe1f64b0992fe2a8196c3b19d89.zip
build: skip opkg host dependency within the SDK
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/Makefile b/package/Makefile
index 1ef501736b..ac8faecef2 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -56,7 +56,9 @@ $(curdir)/merge:
$(curdir)/merge-index: $(curdir)/merge
(cd $(PACKAGE_DIR_ALL) && $(SCRIPT_DIR)/ipkg-make-index.sh . 2>&1 > Packages; )
-$(curdir)/compile: $(curdir)/system/opkg/host/compile
+ifndef SDK
+ $(curdir)/compile: $(curdir)/system/opkg/host/compile
+endif
$(curdir)/install: $(TMP_DIR)/.build $(curdir)/merge $(if $(CONFIG_TARGET_PER_DEVICE_ROOTFS),$(curdir)/merge-index)
- find $(STAGING_DIR_ROOT) -type d | $(XARGS) chmod 0755