aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-07-14 09:57:45 +0000
committerJohn Crispin <john@openwrt.org>2015-07-14 09:57:45 +0000
commit096b3759a98cdbbc710d8620e948eaa7ee2045ed (patch)
treeddec733630e2353a6f2890b81f65410dbfdf165c /package/Makefile
parent3846bb9ac92060669f9c798c3c128057a6d32809 (diff)
downloadupstream-096b3759a98cdbbc710d8620e948eaa7ee2045ed.tar.gz
upstream-096b3759a98cdbbc710d8620e948eaa7ee2045ed.tar.bz2
upstream-096b3759a98cdbbc710d8620e948eaa7ee2045ed.zip
build: Prevent more gzip timestamps
To improve reproducibility, prevent the inclusion of timestamps in the gzip header. Signed-off-by: Reiner Herrmann <reiner@reiner-h.de> SVN-Revision: 46361
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile b/package/Makefile
index 3ef34b1779..cc691b5ad2 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -149,7 +149,7 @@ $(curdir)/index: FORCE
mkdir -p $(PACKAGE_DIR)/$$d; \
cd $(PACKAGE_DIR)/$$d || continue; \
$(SCRIPT_DIR)/ipkg-make-index.sh . 2>&1 > Packages && \
- gzip -9c Packages > Packages.gz; \
+ gzip -9nc Packages > Packages.gz; \
); done
ifdef CONFIG_SIGNED_PACKAGES
@echo Signing package index...