aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2013-10-02 16:38:28 +0000
committerSteven Barth <cyrus@openwrt.org>2013-10-02 16:38:28 +0000
commit03b0c3b5a6f8c032ba10e1e1193eed1145a996c4 (patch)
tree643d0b4257cc3404e7580ce5c5a449ae74845507 /package/Makefile
parent95e9c260bcfef0a45a6f9daf9ff036f1ec75ca4f (diff)
downloadupstream-03b0c3b5a6f8c032ba10e1e1193eed1145a996c4.tar.gz
upstream-03b0c3b5a6f8c032ba10e1e1193eed1145a996c4.tar.bz2
upstream-03b0c3b5a6f8c032ba10e1e1193eed1145a996c4.zip
package/index: fix index creating when building without signing
Signed-off-by: Alexander Couzens <lynxis@fe80.eu> SVN-Revision: 38287
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/Makefile b/package/Makefile
index bac7001c4f..f82654cf90 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -130,16 +130,16 @@ ifndef CONFIG_OPKGSMIME_PASSPHRASE
endif
$(curdir)/index: FORCE
+ @echo Generating package index...
+ @(cd $(PACKAGE_DIR); \
+ $(SCRIPT_DIR)/ipkg-make-index.sh . 2>&1 > Packages && \
+ gzip -9c Packages > Packages.gz )
ifeq ($(call qstrip,$(CONFIG_OPKGSMIME_KEY)),)
@echo Signing key has not been configured
else
ifeq ($(call qstrip,$(CONFIG_OPKGSMIME_CERT)),)
@echo Certificate has not been configured
else
- @echo Generating package index...
- @(cd $(PACKAGE_DIR); \
- $(SCRIPT_DIR)/ipkg-make-index.sh . 2>&1 > Packages && \
- gzip -9c Packages > Packages.gz )
@echo Signing package index...
@(cd $(PACKAGE_DIR); \
openssl smime -binary -in Packages.gz \