aboutsummaryrefslogtreecommitdiffstats
path: root/package/6in4
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-07-05 00:52:10 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-07-05 00:52:10 +0000
commit8aba9a00dc86253f48d878445010cfa68b777b6a (patch)
tree997bfac02a6448c050f59b08e6e25734f4793da8 /package/6in4
parent7c3bbe150ab3e9ec3bdd9e25f8c9e05da5a2ab1b (diff)
downloadupstream-8aba9a00dc86253f48d878445010cfa68b777b6a.tar.gz
upstream-8aba9a00dc86253f48d878445010cfa68b777b6a.tar.bz2
upstream-8aba9a00dc86253f48d878445010cfa68b777b6a.zip
6in4, 6to4: prevent starting the tunnel if kmod-sit is not yet loaded (#9643)
SVN-Revision: 27449
Diffstat (limited to 'package/6in4')
-rw-r--r--package/6in4/Makefile4
-rw-r--r--package/6in4/files/6in4.hotplug5
2 files changed, 7 insertions, 2 deletions
diff --git a/package/6in4/Makefile b/package/6in4/Makefile
index 9a2cfe20d2..14b7eac816 100644
--- a/package/6in4/Makefile
+++ b/package/6in4/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2011 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=6in4
PKG_VERSION:=9
-PKG_RELEASE:=1
+PKG_RELEASE:=2
include $(INCLUDE_DIR)/package.mk
diff --git a/package/6in4/files/6in4.hotplug b/package/6in4/files/6in4.hotplug
index 49667a815e..9df993498a 100644
--- a/package/6in4/files/6in4.hotplug
+++ b/package/6in4/files/6in4.hotplug
@@ -20,6 +20,11 @@ if [ "$ACTION" = ifup ]; then
local wanip=$(find_6in4_wanip "$wandev")
[ -n "$wanip" ] && {
+ lsmod | grep -q ^sit || {
+ logger -t 6in4-update "Tunneling driver not loaded yet, deferring action"
+ exit 0
+ }
+
local tunnelid
config_get tunnelid "$cfg" tunnelid