aboutsummaryrefslogtreecommitdiffstats
path: root/openwrt/toolchain/gcc/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2006-02-06 11:26:51 +0000
committerImre Kaloz <kaloz@openwrt.org>2006-02-06 11:26:51 +0000
commitf899e1bc452ec65e58cbeff9a0f8f79e8d1eeec7 (patch)
tree67edd7a7ab0241a03d27103a9f53afb574a514f0 /openwrt/toolchain/gcc/Makefile
parentb37df06d501fbae046c15d91c42eb5c8548ffc8e (diff)
downloadupstream-f899e1bc452ec65e58cbeff9a0f8f79e8d1eeec7.tar.gz
upstream-f899e1bc452ec65e58cbeff9a0f8f79e8d1eeec7.tar.bz2
upstream-f899e1bc452ec65e58cbeff9a0f8f79e8d1eeec7.zip
make gcc4 depend on libgcc, and disable the libgcc hack for it
SVN-Revision: 3161
Diffstat (limited to 'openwrt/toolchain/gcc/Makefile')
-rw-r--r--openwrt/toolchain/gcc/Makefile6
1 files changed, 1 insertions, 5 deletions
diff --git a/openwrt/toolchain/gcc/Makefile b/openwrt/toolchain/gcc/Makefile
index 2d24cdd13e..26e17ad61e 100644
--- a/openwrt/toolchain/gcc/Makefile
+++ b/openwrt/toolchain/gcc/Makefile
@@ -193,11 +193,7 @@ endif
# We do another ugly hack here because the standard behaviour is
# to include a reference to libgcc.so.1 in all binaries. For flash space
# saving, we change the specs file to link in a static libgcc here.
- if [ ! -f $(STAGING_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs ] ; then \
- echo staging dir specs file is missing, assuming GCC 4.x ; \
- $(STAGING_DIR)/bin/$(REAL_GNU_TARGET_NAME)-gcc -dumpspecs > $(STAGING_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs; \
- fi;
- if grep -q as-needed $(STAGING_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs; then \
+ if [ -f $(STAGING_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs ] ; then \
patch -d $(STAGING_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/ -p0 < ./$(GCC_VERSION)/static-libgcc.patch.conditional ; \
fi;