aboutsummaryrefslogtreecommitdiffstats
path: root/openwrt/toolchain/gcc/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-01-27 18:51:42 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-01-27 18:51:42 +0000
commit34a6cbba4684964e1fb0ba4c0df6a80335ba738a (patch)
tree9dcedc8d28f6f7b5e5daa389c0227f01d8171771 /openwrt/toolchain/gcc/Makefile
parentd35d0c1ccc6505f38e22bfa9fdcd382270aa3ff6 (diff)
downloadupstream-34a6cbba4684964e1fb0ba4c0df6a80335ba738a.tar.gz
upstream-34a6cbba4684964e1fb0ba4c0df6a80335ba738a.tar.bz2
upstream-34a6cbba4684964e1fb0ba4c0df6a80335ba738a.zip
add 'OpenWrt-2.0' to gcc version info
SVN-Revision: 3058
Diffstat (limited to 'openwrt/toolchain/gcc/Makefile')
-rw-r--r--openwrt/toolchain/gcc/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/openwrt/toolchain/gcc/Makefile b/openwrt/toolchain/gcc/Makefile
index f6f4acaab6..57debe12b8 100644
--- a/openwrt/toolchain/gcc/Makefile
+++ b/openwrt/toolchain/gcc/Makefile
@@ -79,6 +79,8 @@ ifeq ("$(strip $(ARCH))","armeb")
$(SCRIPT_DIR)/patch-kernel.sh $(GCC_DIR) ./$(GCC_VERSION) arm-softfloat.patch.conditional
endif
endif
+ $(SED) 's,\(version_string.. = "[0-9\.]*\).*\(";\),\1 (OpenWrt-2.0)\2,' $(GCC_DIR)/gcc/version.c
+ $(SED) 's,\(bug_report_url.. = "\).*\(";\),\1<URL:https://dev.openwrt.org/>\2,' $(GCC_DIR)/gcc/version.c
touch $(GCC_DIR)/.patched
# The --without-headers option stopped working with gcc 3.0 and has never been