aboutsummaryrefslogtreecommitdiffstats
path: root/openwrt/package/vpnc
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2005-12-13 09:37:29 +0000
committerFlorian Fainelli <florian@openwrt.org>2005-12-13 09:37:29 +0000
commit10711d79714504f7250684bcef475d35272f5f04 (patch)
tree04f073b1850eb2ded7e266849d2cecacb9efabee /openwrt/package/vpnc
parent636b2d3d83444bfa2184130bc061f93df547be77 (diff)
downloadupstream-10711d79714504f7250684bcef475d35272f5f04.tar.gz
upstream-10711d79714504f7250684bcef475d35272f5f04.tar.bz2
upstream-10711d79714504f7250684bcef475d35272f5f04.zip
Added vpnc, a cicso3000 vpn concentrator client
SVN-Revision: 2647
Diffstat (limited to 'openwrt/package/vpnc')
-rwxr-xr-xopenwrt/package/vpnc/Config.in8
-rwxr-xr-xopenwrt/package/vpnc/Makefile31
-rwxr-xr-xopenwrt/package/vpnc/ipkg/vpnc.control6
-rw-r--r--openwrt/package/vpnc/patches/01-no_man.patch27
4 files changed, 72 insertions, 0 deletions
diff --git a/openwrt/package/vpnc/Config.in b/openwrt/package/vpnc/Config.in
new file mode 100755
index 0000000000..2b3a42356e
--- /dev/null
+++ b/openwrt/package/vpnc/Config.in
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_VPNC
+ tristate "vpnc............................. client for cisco3000 VPN Concentrator."
+ default m if CONFIG_DEVEL
+ depends on BR2_PACKAGE_KMOD_TUN
+ depends on BR2_PACKAGE_LIBGPG_ERROR
+ depends on BR2_PACKAGE_LIBGCRYPT
+ help
+ Client for cisco3000 VPN Concentrator.
diff --git a/openwrt/package/vpnc/Makefile b/openwrt/package/vpnc/Makefile
new file mode 100755
index 0000000000..6aec933e71
--- /dev/null
+++ b/openwrt/package/vpnc/Makefile
@@ -0,0 +1,31 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=vpnc
+PKG_VERSION:=0.3.3
+PKG_RELEASE:=1
+
+PKG_MD5SUM:=e7518cff21326fe7eb9795b60c25ae6a
+PKG_SOURCE_URL:=http://www.unix-ag.uni-kl.de/~massar/vpnc/
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_CAT:=zcat
+
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,VPNC,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+ touch $@
+
+$(PKG_BUILD_DIR)/.built:
+ $(MAKE) STAGING_DIR=$(STAGING_DIR) CC=$(TARGET_CC) DESTDIR=$(PKG_INSTALL_DIR) -C $(PKG_BUILD_DIR) all install
+ touch $@
+
+$(IPKG_VPNC):
+ mkdir -p $(IDIR_VPNC)
+ cp -fpR $(PKG_INSTALL_DIR)/* $(IDIR_VPNC)/
+ $(RSTRIP) $(IDIR_VPNC)
+ $(IPKG_BUILD) $(IDIR_VPNC) $(PACKAGE_DIR)
diff --git a/openwrt/package/vpnc/ipkg/vpnc.control b/openwrt/package/vpnc/ipkg/vpnc.control
new file mode 100755
index 0000000000..5087af9b29
--- /dev/null
+++ b/openwrt/package/vpnc/ipkg/vpnc.control
@@ -0,0 +1,6 @@
+Package: vpnc
+Section: net
+Architecture: mipsel
+Priority: optional
+Description: client for cisco3000 VPN Concentrator.
+Depends: libgpg-error libgcrypt kmod-tun
diff --git a/openwrt/package/vpnc/patches/01-no_man.patch b/openwrt/package/vpnc/patches/01-no_man.patch
new file mode 100644
index 0000000000..a5cc3952c4
--- /dev/null
+++ b/openwrt/package/vpnc/patches/01-no_man.patch
@@ -0,0 +1,27 @@
+diff -urN orig/vpnc-0.3.3/Makefile vpnc-0.3.3/Makefile
+--- orig/vpnc-0.3.3/Makefile 2005-05-01 22:30:35.000000000 +0200
++++ vpnc-0.3.3/Makefile 2005-12-13 10:30:56.000000000 +0100
+@@ -22,9 +22,8 @@
+ SBINDIR=$(PREFIX)/sbin
+ MANDIR=$(PREFIX)/share/man
+
+-CC=gcc
+-CFLAGS=-W -Wall -O -g '-DVERSION="$(shell cat VERSION)"' $(shell libgcrypt-config --cflags)
+-LDFLAGS=-g $(shell libgcrypt-config --libs)
++CFLAGS=-W -Wall -O -I$(STAGING_DIR)/usr/include '-DVERSION="$(shell cat VERSION)"' $(shell libgcrypt-config --cflags)
++LDFLAGS=-L$(STAGING_DIR)/usr/lib $(shell libgcrypt-config --libs)
+
+ ifeq ($(shell uname -s), Linux)
+ SYSDEP=sysdep-linux.o
+@@ -83,10 +82,9 @@
+ all : vpnc
+
+ install :
+- install -d $(DESTDIR)$(ETCDIR) $(DESTDIR)$(SBINDIR) $(DESTDIR)$(MANDIR)/man8
++ install -d $(DESTDIR)$(ETCDIR) $(DESTDIR)$(SBINDIR)
+ install vpnc.conf vpnc-script $(DESTDIR)$(ETCDIR)
+ install vpnc vpnc-disconnect $(DESTDIR)$(SBINDIR)
+- install vpnc.8 $(DESTDIR)$(MANDIR)/man8
+
+ install-strip :
+ install -d $(DESTDIR)$(ETCDIR) $(DESTDIR)$(SBINDIR) $(DESTDIR)$(MANDIR)/man8