aboutsummaryrefslogtreecommitdiffstats
path: root/openwrt/package/vpnc/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-12-14 00:16:01 +0000
committerNicolas Thill <nico@openwrt.org>2005-12-14 00:16:01 +0000
commit3f774a5f9d4c5b3c98f93866a56fac0b80189a0f (patch)
tree44d57fdc6440f0378dbdedf2f473dd43f6d7449a /openwrt/package/vpnc/Makefile
parent2ccbafe84ff4b09e22836b48a353021eb170b385 (diff)
downloadupstream-3f774a5f9d4c5b3c98f93866a56fac0b80189a0f.tar.gz
upstream-3f774a5f9d4c5b3c98f93866a56fac0b80189a0f.tar.bz2
upstream-3f774a5f9d4c5b3c98f93866a56fac0b80189a0f.zip
install in /usr instead of /usr/local/, add an ipkg/conffiles, add an Id tag to the Makefile
SVN-Revision: 2666
Diffstat (limited to 'openwrt/package/vpnc/Makefile')
-rw-r--r--[-rwxr-xr-x]openwrt/package/vpnc/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/openwrt/package/vpnc/Makefile b/openwrt/package/vpnc/Makefile
index 6aec933e71..7513290eba 100755..100644
--- a/openwrt/package/vpnc/Makefile
+++ b/openwrt/package/vpnc/Makefile
@@ -1,3 +1,5 @@
+# $Id$
+
include $(TOPDIR)/rules.mk
PKG_NAME:=vpnc
@@ -21,11 +23,16 @@ $(PKG_BUILD_DIR)/.configured:
touch $@
$(PKG_BUILD_DIR)/.built:
- $(MAKE) STAGING_DIR=$(STAGING_DIR) CC=$(TARGET_CC) DESTDIR=$(PKG_INSTALL_DIR) -C $(PKG_BUILD_DIR) all install
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ CC=$(TARGET_CC) \
+ STAGING_DIR=$(STAGING_DIR) \
+ DESTDIR=$(PKG_INSTALL_DIR) \
+ PREFIX=/usr \
+ all install
touch $@
$(IPKG_VPNC):
- mkdir -p $(IDIR_VPNC)
+ install -d -m0755 $(IDIR_VPNC)
cp -fpR $(PKG_INSTALL_DIR)/* $(IDIR_VPNC)/
$(RSTRIP) $(IDIR_VPNC)
$(IPKG_BUILD) $(IDIR_VPNC) $(PACKAGE_DIR)