aboutsummaryrefslogtreecommitdiffstats
path: root/openwrt/package/updatedd
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-07 11:57:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-07 11:57:20 +0000
commitd58a09110ccfa95f06c983fe796806f2e035c9d2 (patch)
tree4b825dc642cb6eb9a060e54bf8d69288fbee4904 /openwrt/package/updatedd
parentaf034797eeb62b62ac05442d5a688b28ccd0f16b (diff)
downloadupstream-d58a09110ccfa95f06c983fe796806f2e035c9d2.tar.gz
upstream-d58a09110ccfa95f06c983fe796806f2e035c9d2.tar.bz2
upstream-d58a09110ccfa95f06c983fe796806f2e035c9d2.zip
move old kamikaze out of trunk - will put buildroot-ng in there as soon as all the developers are ready
SVN-Revision: 4944
Diffstat (limited to 'openwrt/package/updatedd')
-rw-r--r--openwrt/package/updatedd/Config.in73
-rw-r--r--openwrt/package/updatedd/Makefile80
-rw-r--r--openwrt/package/updatedd/files/S55ddns10
-rw-r--r--openwrt/package/updatedd/ipkg/updatedd-mod-changeip.control4
-rw-r--r--openwrt/package/updatedd/ipkg/updatedd-mod-dyndns.control4
-rw-r--r--openwrt/package/updatedd/ipkg/updatedd-mod-eurodyndns.control4
-rw-r--r--openwrt/package/updatedd/ipkg/updatedd-mod-hn.control4
-rw-r--r--openwrt/package/updatedd/ipkg/updatedd-mod-noip.control4
-rw-r--r--openwrt/package/updatedd/ipkg/updatedd-mod-ods.control4
-rw-r--r--openwrt/package/updatedd/ipkg/updatedd-mod-ovh.control4
-rw-r--r--openwrt/package/updatedd/ipkg/updatedd-mod-regfish.control4
-rw-r--r--openwrt/package/updatedd/ipkg/updatedd-mod-tzo.control4
-rw-r--r--openwrt/package/updatedd/ipkg/updatedd.control4
13 files changed, 0 insertions, 203 deletions
diff --git a/openwrt/package/updatedd/Config.in b/openwrt/package/updatedd/Config.in
deleted file mode 100644
index 77bda5e192..0000000000
--- a/openwrt/package/updatedd/Config.in
+++ /dev/null
@@ -1,73 +0,0 @@
-menu "updatedd.......................... A tool to update dynamic dns services"
-
-config BR2_PACKAGE_UPDATEDD
- prompt "updatedd.......................... A tool to update dynamic DNS services"
- tristate
- default m if CONFIG_DEVEL
- help
- Updatedd is a small tool that will update one of many dynamic
- dns services on boot.
-
- Please look at the /etc/init.d/S50ddns script for more info.
-
- http://www.philipp-benner.de/updatedd/
-
-if BR2_PACKAGE_UPDATEDD
-comment "Plugin Dynamic DNS service"
-endif
-
-config BR2_PACKAGE_UPDATEDD_MOD_CHANGEIP
- prompt "updatedd-mod-changeip........... changeip.com"
- tristate
- depends on BR2_PACKAGE_UPDATEDD
- default m if CONFIG_DEVEL
-
-config BR2_PACKAGE_UPDATEDD_MOD_DYNDNS
- prompt "updatedd-mod-dyndns............. dyndns.org"
- tristate
- depends on BR2_PACKAGE_UPDATEDD
- default m if CONFIG_DEVEL
-
-config BR2_PACKAGE_UPDATEDD_MOD_EURODYNDNS
- prompt "updatedd-mod-eurodyndns......... eurodyndns.org"
- tristate
- depends on BR2_PACKAGE_UPDATEDD
- default m if CONFIG_DEVEL
-
-config BR2_PACKAGE_UPDATEDD_MOD_HN
- prompt "updatedd-mod-hn................. hn.org"
- tristate
- depends on BR2_PACKAGE_UPDATEDD
- default m if CONFIG_DEVEL
-
-config BR2_PACKAGE_UPDATEDD_MOD_NOIP
- prompt "updatedd-mod-noip............... no-ip.com"
- tristate
- depends on BR2_PACKAGE_UPDATEDD
- default m if CONFIG_DEVEL
-
-config BR2_PACKAGE_UPDATEDD_MOD_ODS
- prompt "updatedd-mod-ods................ ods.org"
- tristate
- depends on BR2_PACKAGE_UPDATEDD
- default m if CONFIG_DEVEL
-
-config BR2_PACKAGE_UPDATEDD_MOD_OVH
- prompt "updatedd-mod-ovh................ ovh.com"
- tristate
- depends on BR2_PACKAGE_UPDATEDD
- default m if CONFIG_DEVEL
-
-config BR2_PACKAGE_UPDATEDD_MOD_REGFISH
- prompt "updatedd-mod-regfish............ regfish.com"
- tristate
- depends on BR2_PACKAGE_UPDATEDD
- default m if CONFIG_DEVEL
-
-config BR2_PACKAGE_UPDATEDD_MOD_TZO
- prompt "updatedd-mod-tzo................ tzo.com"
- tristate
- depends on BR2_PACKAGE_UPDATEDD
- default m if CONFIG_DEVEL
-
-endmenu
diff --git a/openwrt/package/updatedd/Makefile b/openwrt/package/updatedd/Makefile
deleted file mode 100644
index 1edc3dd4e8..0000000000
--- a/openwrt/package/updatedd/Makefile
+++ /dev/null
@@ -1,80 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=updatedd
-PKG_VERSION:=2.5
-PKG_RELEASE:=1
-PKG_MD5SUM:=2957496de0c8e08e9c6492fabf1a88be
-
-PKG_SOURCE_URL:=http://savannah.nongnu.org/download/updatedd/
-PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-define PKG_mod_template
-
-$$(IPKG_$(1)):
- install -d -m0755 $$(IDIR_$(1))/usr/lib/updatedd
- install -m0755 $(PKG_INSTALL_DIR)/usr/lib/updatedd/$(2).so $$(IDIR_$(1))/usr/lib/updatedd/
- $(RSTRIP) $$(IDIR_$(1))
- $(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
-
-endef
-
-$(eval $(call PKG_template,UPDATEDD,updatedd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,UPDATEDD_MOD_CHANGEIP,updatedd-mod-changeip,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,UPDATEDD_MOD_DYNDNS,updatedd-mod-dyndns,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,UPDATEDD_MOD_EURODYNDNS,updatedd-mod-eurodyndns,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,UPDATEDD_MOD_HN,updatedd-mod-hn,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,UPDATEDD_MOD_NOIP,updatedd-mod-noip,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,UPDATEDD_MOD_ODS,updatedd-mod-ods,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,UPDATEDD_MOD_OVH,updatedd-mod-ovh,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,UPDATEDD_MOD_REGFISH,updatedd-mod-regfish,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,UPDATEDD_MOD_TZO,updatedd-mod-tzo,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(eval $(call PKG_mod_template,UPDATEDD_MOD_CHANGEIP,changeip))
-$(eval $(call PKG_mod_template,UPDATEDD_MOD_DYNDNS,dyndns))
-$(eval $(call PKG_mod_template,UPDATEDD_MOD_EURODYNDNS,eurodyndns))
-$(eval $(call PKG_mod_template,UPDATEDD_MOD_HN,hn))
-$(eval $(call PKG_mod_template,UPDATEDD_MOD_NOIP,noip))
-$(eval $(call PKG_mod_template,UPDATEDD_MOD_ODS,ods))
-$(eval $(call PKG_mod_template,UPDATEDD_MOD_OVH,ovh))
-$(eval $(call PKG_mod_template,UPDATEDD_MOD_REGFISH,regfish))
-$(eval $(call PKG_mod_template,UPDATEDD_MOD_TZO,tzo))
-
-$(PKG_BUILD_DIR)/.configured:
- (cd $(PKG_BUILD_DIR); \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --prefix=/usr \
- --sysconfdir=/etc \
- );
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- rm -rf $(PKG_INSTALL_DIR)
- mkdir -p $(PKG_INSTALL_DIR)
- $(TARGET_CONFIGURE_OPTS) \
- $(MAKE) -C $(PKG_BUILD_DIR) \
- $(TARGET_CONFIGURE_OPTS) \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- all install
- touch $@
-
-$(IPKG_UPDATEDD):
- install -d -m0755 $(IDIR_UPDATEDD)/etc/init.d
- install -m0755 ./files/S55ddns $(IDIR_UPDATEDD)/etc/init.d/
- install -d -m0755 $(IDIR_UPDATEDD)/usr/bin
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/updatedd $(IDIR_UPDATEDD)/usr/bin/
- install -d -m0755 $(IDIR_UPDATEDD)/usr/lib/updatedd
- $(RSTRIP) $(IDIR_UPDATEDD)
- $(IPKG_BUILD) $(IDIR_UPDATEDD) $(PACKAGE_DIR)
diff --git a/openwrt/package/updatedd/files/S55ddns b/openwrt/package/updatedd/files/S55ddns
deleted file mode 100644
index b02d579178..0000000000
--- a/openwrt/package/updatedd/files/S55ddns
+++ /dev/null
@@ -1,10 +0,0 @@
-ddnsupdate=$(nvram get ddns_update)
-[ "$ddnsupdate" = 1 ]&& {
- service=$(nvram get ddns_service)
- uname=$(nvram get ddns_user)
- passwd=$(nvram get ddns_password)
- host=$(nvram get ddns_host)
-
- /usr/bin/updatedd -Y $service -- $uname:$passwd $host
-}
-
diff --git a/openwrt/package/updatedd/ipkg/updatedd-mod-changeip.control b/openwrt/package/updatedd/ipkg/updatedd-mod-changeip.control
deleted file mode 100644
index 986752b77d..0000000000
--- a/openwrt/package/updatedd/ipkg/updatedd-mod-changeip.control
+++ /dev/null
@@ -1,4 +0,0 @@
-Package: updatedd-mod-changeip
-Priority: optional
-Section: net
-Description: Plugin for updatedd, support for changeip.com dynamic DNS service.
diff --git a/openwrt/package/updatedd/ipkg/updatedd-mod-dyndns.control b/openwrt/package/updatedd/ipkg/updatedd-mod-dyndns.control
deleted file mode 100644
index 93c62fd47b..0000000000
--- a/openwrt/package/updatedd/ipkg/updatedd-mod-dyndns.control
+++ /dev/null
@@ -1,4 +0,0 @@
-Package: updatedd-mod-dyndns
-Priority: optional
-Section: net
-Description: Plugin for updatedd, support for dyndns.org dynamic DNS service.
diff --git a/openwrt/package/updatedd/ipkg/updatedd-mod-eurodyndns.control b/openwrt/package/updatedd/ipkg/updatedd-mod-eurodyndns.control
deleted file mode 100644
index f29e59810c..0000000000
--- a/openwrt/package/updatedd/ipkg/updatedd-mod-eurodyndns.control
+++ /dev/null
@@ -1,4 +0,0 @@
-Package: updatedd-mod-eurodyndns
-Priority: optional
-Section: net
-Description: Plugin for updatedd, support for eurodyndns.org dynamic DNS service.
diff --git a/openwrt/package/updatedd/ipkg/updatedd-mod-hn.control b/openwrt/package/updatedd/ipkg/updatedd-mod-hn.control
deleted file mode 100644
index d5b57c076a..0000000000
--- a/openwrt/package/updatedd/ipkg/updatedd-mod-hn.control
+++ /dev/null
@@ -1,4 +0,0 @@
-Package: updatedd-mod-hn
-Priority: optional
-Section: net
-Description: Plugin for updatedd, support for hn.org dynamic DNS service.
diff --git a/openwrt/package/updatedd/ipkg/updatedd-mod-noip.control b/openwrt/package/updatedd/ipkg/updatedd-mod-noip.control
deleted file mode 100644
index 925bd7685b..0000000000
--- a/openwrt/package/updatedd/ipkg/updatedd-mod-noip.control
+++ /dev/null
@@ -1,4 +0,0 @@
-Package: updatedd-mod-noip
-Priority: optional
-Section: net
-Description: Plugin for updatedd, support for no-ip.org dynamic DNS service.
diff --git a/openwrt/package/updatedd/ipkg/updatedd-mod-ods.control b/openwrt/package/updatedd/ipkg/updatedd-mod-ods.control
deleted file mode 100644
index e47b4a6e36..0000000000
--- a/openwrt/package/updatedd/ipkg/updatedd-mod-ods.control
+++ /dev/null
@@ -1,4 +0,0 @@
-Package: updatedd-mod-ods
-Priority: optional
-Section: net
-Description: Plugin for updatedd, support for ods.org dynamic DNS service.
diff --git a/openwrt/package/updatedd/ipkg/updatedd-mod-ovh.control b/openwrt/package/updatedd/ipkg/updatedd-mod-ovh.control
deleted file mode 100644
index d1eb9f219a..0000000000
--- a/openwrt/package/updatedd/ipkg/updatedd-mod-ovh.control
+++ /dev/null
@@ -1,4 +0,0 @@
-Package: updatedd-mod-ovh
-Priority: optional
-Section: net
-Description: Plugin for updatedd, support for ovh.com dynamic DNS service.
diff --git a/openwrt/package/updatedd/ipkg/updatedd-mod-regfish.control b/openwrt/package/updatedd/ipkg/updatedd-mod-regfish.control
deleted file mode 100644
index f17fffe875..0000000000
--- a/openwrt/package/updatedd/ipkg/updatedd-mod-regfish.control
+++ /dev/null
@@ -1,4 +0,0 @@
-Package: updatedd-mod-regfish
-Priority: optional
-Section: net
-Description: Plugin for updatedd, support for regfish.com dynamic DNS service.
diff --git a/openwrt/package/updatedd/ipkg/updatedd-mod-tzo.control b/openwrt/package/updatedd/ipkg/updatedd-mod-tzo.control
deleted file mode 100644
index 089dfde077..0000000000
--- a/openwrt/package/updatedd/ipkg/updatedd-mod-tzo.control
+++ /dev/null
@@ -1,4 +0,0 @@
-Package: updatedd-mod-tzo
-Priority: optional
-Section: net
-Description: Plugin for updatedd, support for tzo.com dynamic DNS service.
diff --git a/openwrt/package/updatedd/ipkg/updatedd.control b/openwrt/package/updatedd/ipkg/updatedd.control
deleted file mode 100644
index f3eafcb48b..0000000000
--- a/openwrt/package/updatedd/ipkg/updatedd.control
+++ /dev/null
@@ -1,4 +0,0 @@
-Package: updatedd
-Priority: optional
-Section: net
-Description: A tool to update dynamic dns services.