aboutsummaryrefslogtreecommitdiffstats
path: root/openwrt/package/rsync
diff options
context:
space:
mode:
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>2005-06-12 11:49:40 +0000
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>2005-06-12 11:49:40 +0000
commit28774fd6017e0d1407d1514f736088f8c7c486d5 (patch)
tree45d7f8e1254e67b0a0c22f4864e8ee5557d7edfc /openwrt/package/rsync
parentd9f3de07a6a23703e8ced04845a0d02d872e4f73 (diff)
downloadupstream-28774fd6017e0d1407d1514f736088f8c7c486d5.tar.gz
upstream-28774fd6017e0d1407d1514f736088f8c7c486d5.tar.bz2
upstream-28774fd6017e0d1407d1514f736088f8c7c486d5.zip
add rsync client
SVN-Revision: 1217
Diffstat (limited to 'openwrt/package/rsync')
-rw-r--r--openwrt/package/rsync/Config.in9
-rw-r--r--openwrt/package/rsync/Makefile63
-rw-r--r--openwrt/package/rsync/ipkg/rsync.control7
3 files changed, 79 insertions, 0 deletions
diff --git a/openwrt/package/rsync/Config.in b/openwrt/package/rsync/Config.in
new file mode 100644
index 0000000000..f2849533bc
--- /dev/null
+++ b/openwrt/package/rsync/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_RSYNC
+ tristate "rsync"
+ select BR2_PACKAGE_LIBPOPT
+ default m if CONFIG_DEVEL
+ help
+
+ utility that provides fast incremental file transfer
+
+ http://rsync.samba.org
diff --git a/openwrt/package/rsync/Makefile b/openwrt/package/rsync/Makefile
new file mode 100644
index 0000000000..0cad9c7d23
--- /dev/null
+++ b/openwrt/package/rsync/Makefile
@@ -0,0 +1,63 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=rsync
+PKG_VERSION:=2.6.5
+PKG_RELEASE:=0
+PKG_MD5SUM:=3691cdf1540d0649ba679edce6bae8fc
+
+PKG_SOURCE_URL:=http://rsync.samba.org/ftp/rsync/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,RSYNC,rsync,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+ (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+ $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
+ LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --program-prefix="" \
+ --program-suffix="" \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --datadir=/usr/share \
+ --includedir=/usr/include \
+ --infodir=/usr/share/info \
+ --libdir=/usr/lib \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --mandir=/usr/share/man \
+ --sbindir=/usr/sbin \
+ --sysconfdir=/etc \
+ $(DISABLE_LARGEFILE) \
+ $(DISABLE_NLS) \
+ );
+ touch $@
+
+$(PKG_BUILD_DIR)/.built:
+ rm -rf $(PKG_INSTALL_DIR)
+ mkdir -p $(PKG_INSTALL_DIR)
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ $(TARGET_CONFIGURE_OPTS) \
+ DESTDIR="$(PKG_INSTALL_DIR)" \
+ all install
+ touch $@
+
+$(IPKG_RSYNC):
+ install -d -m0755 $(IDIR_RSYNC)/usr/bin
+ cp -fpR $(PKG_INSTALL_DIR)/usr/bin/* $(IDIR_RSYNC)/usr/bin
+ $(RSTRIP) $(IDIR_RSYNC)
+ $(IPKG_BUILD) $(IDIR_RSYNC) $(PACKAGE_DIR)
diff --git a/openwrt/package/rsync/ipkg/rsync.control b/openwrt/package/rsync/ipkg/rsync.control
new file mode 100644
index 0000000000..55b4d7d132
--- /dev/null
+++ b/openwrt/package/rsync/ipkg/rsync.control
@@ -0,0 +1,7 @@
+Package: rsync
+Priority: optional
+Section: net
+Maintainer: OpenWrt Developers <bugs@openwrt.org>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/rsync/
+Depends: libpopt
+Description: utility that provides fast incremental file transfer