aboutsummaryrefslogtreecommitdiffstats
path: root/openwrt/package/lighttpd
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2006-04-16 22:26:21 +0000
committerFlorian Fainelli <florian@openwrt.org>2006-04-16 22:26:21 +0000
commit624bba95de47393ddbc7506665611f45db8a03a2 (patch)
treeb1fd2c1dcf9e00ca103a28d857592ef607df84aa /openwrt/package/lighttpd
parent965f68dcac2d7960219818ae5a7eb30da669aae9 (diff)
downloadupstream-624bba95de47393ddbc7506665611f45db8a03a2.tar.gz
upstream-624bba95de47393ddbc7506665611f45db8a03a2.tar.bz2
upstream-624bba95de47393ddbc7506665611f45db8a03a2.zip
Create iptraf directories Build mod_webdav for lighttpd Fix libtool patch
SVN-Revision: 3661
Diffstat (limited to 'openwrt/package/lighttpd')
-rw-r--r--openwrt/package/lighttpd/Makefile5
-rw-r--r--openwrt/package/lighttpd/ipkg/lighttpd-mod-webdav.control5
-rw-r--r--openwrt/package/lighttpd/patches/501-libxml2_includes.patch12
3 files changed, 21 insertions, 1 deletions
diff --git a/openwrt/package/lighttpd/Makefile b/openwrt/package/lighttpd/Makefile
index d15efe4560..5b53d33a12 100644
--- a/openwrt/package/lighttpd/Makefile
+++ b/openwrt/package/lighttpd/Makefile
@@ -42,6 +42,7 @@ $(eval $(call PKG_template,LIGHTTPD_MOD_SIMPLE_VHOST,lighttpd-mod-simple-vhost,$
$(eval $(call PKG_template,LIGHTTPD_MOD_SSI,lighttpd-mod-ssi,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(eval $(call PKG_template,LIGHTTPD_MOD_STATUS,lighttpd-mod-status,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(eval $(call PKG_template,LIGHTTPD_MOD_USERTRACK,lighttpd-mod-usertrack,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,LIGHTTPD_MOD_WEBDAV,lighttpd-mod-webdav,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(eval $(call PKG_mod_template,LIGHTTPD_MOD_ACCESSLOG,accesslog))
$(eval $(call PKG_mod_template,LIGHTTPD_MOD_ALIAS,alias))
@@ -58,6 +59,7 @@ $(eval $(call PKG_mod_template,LIGHTTPD_MOD_SIMPLE_VHOST,simple_vhost))
$(eval $(call PKG_mod_template,LIGHTTPD_MOD_SSI,ssi))
$(eval $(call PKG_mod_template,LIGHTTPD_MOD_STATUS,status))
$(eval $(call PKG_mod_template,LIGHTTPD_MOD_USERTRACK,usertrack))
+$(eval $(call PKG_mod_template,LIGHTTPD_MOD_WEBDAV,webdav))
$(PKG_BUILD_DIR)/.configured:
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
@@ -101,7 +103,7 @@ $(PKG_BUILD_DIR)/.configured:
--with-openssl="$(STAGING_DIR)/usr" \
--with-pcre \
--without-valgrind \
- --without-webdav-props \
+ --with-webdav-props \
)
touch $@
@@ -109,6 +111,7 @@ $(PKG_BUILD_DIR)/.built:
rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
+ STAGING_DIR=$(STAGING_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
all install
touch $@
diff --git a/openwrt/package/lighttpd/ipkg/lighttpd-mod-webdav.control b/openwrt/package/lighttpd/ipkg/lighttpd-mod-webdav.control
new file mode 100644
index 0000000000..0d5110ce6f
--- /dev/null
+++ b/openwrt/package/lighttpd/ipkg/lighttpd-mod-webdav.control
@@ -0,0 +1,5 @@
+Package: lighttpd-mod-webdav
+Priority: optional
+Section: net
+Description: a webdav module for lighttpd
+Depends: lighttpd, libxml2, sqlite
diff --git a/openwrt/package/lighttpd/patches/501-libxml2_includes.patch b/openwrt/package/lighttpd/patches/501-libxml2_includes.patch
new file mode 100644
index 0000000000..4b7943d9d1
--- /dev/null
+++ b/openwrt/package/lighttpd/patches/501-libxml2_includes.patch
@@ -0,0 +1,12 @@
+diff -urN lighttpd-1.4.11/src/Makefile.in lighttpd-1.4.11.new/src/Makefile.in
+--- lighttpd-1.4.11/src/Makefile.in 2006-03-07 13:21:02.000000000 +0100
++++ lighttpd-1.4.11.new/src/Makefile.in 2006-04-17 00:16:12.000000000 +0200
+@@ -409,7 +409,7 @@
+ STRIP = @STRIP@
+ U = @U@
+ VERSION = @VERSION@
+-XML_CFLAGS = @XML_CFLAGS@
++XML_CFLAGS = -I$(STAGING_DIR)/usr/include/libxml2
+ XML_LIBS = @XML_LIBS@
+ Z_LIB = @Z_LIB@
+ ac_ct_AR = @ac_ct_AR@