aboutsummaryrefslogtreecommitdiffstats
path: root/openwrt/package/amwall/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-11-07 11:38:54 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-11-07 11:38:54 +0000
commitf313afc53bb74601021014b2a1aae98b9c9331fb (patch)
treee3467c3e7cce1aaf7a8a40eb87e516a061cb43cf /openwrt/package/amwall/Makefile
parentc358834657d797cc4c528939c1345411e43ac5cf (diff)
downloadupstream-f313afc53bb74601021014b2a1aae98b9c9331fb.tar.gz
upstream-f313afc53bb74601021014b2a1aae98b9c9331fb.tar.bz2
upstream-f313afc53bb74601021014b2a1aae98b9c9331fb.zip
fix amwall compile (conflict with V=)
SVN-Revision: 2374
Diffstat (limited to 'openwrt/package/amwall/Makefile')
-rw-r--r--openwrt/package/amwall/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/openwrt/package/amwall/Makefile b/openwrt/package/amwall/Makefile
index 173a5d467b..3fedcab960 100644
--- a/openwrt/package/amwall/Makefile
+++ b/openwrt/package/amwall/Makefile
@@ -18,11 +18,15 @@ include $(TOPDIR)/package/rules.mk
$(eval $(call PKG_template,AMWALL,amwall,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.prepared
+$(PKG_BUILD_DIR)/.configured:
+ touch $@
+
+$(PKG_BUILD_DIR)/.built:
rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
+ V= \
LDIR=$(PKG_BUILD_DIR) \
AMSEL_INCLUDE="$(STAGING_DIR)/usr/include" \
OPT_LDFLAGS="-L$(STAGING_DIR)/usr/lib" \