aboutsummaryrefslogtreecommitdiffstats
path: root/openwrt/Makefile
diff options
context:
space:
mode:
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>2005-02-23 21:50:10 +0000
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>2005-02-23 21:50:10 +0000
commite3a3457a9d50dff8dac230880b7523a208d0c85f (patch)
treefa2b49bc98a06fbd53fbff73087275913ab8cd1f /openwrt/Makefile
parentfb1a0ad0ef813ebb96808a9e0097550f3e99a5ed (diff)
downloadupstream-e3a3457a9d50dff8dac230880b7523a208d0c85f.tar.gz
upstream-e3a3457a9d50dff8dac230880b7523a208d0c85f.tar.bz2
upstream-e3a3457a9d50dff8dac230880b7523a208d0c85f.zip
I do not believe that users will cleanup kernelsource, when switching rootfs. force it with scripts and Makefile changes from Felix Fietkau <nbd@vd-s.ath.cx>
SVN-Revision: 290
Diffstat (limited to 'openwrt/Makefile')
-rw-r--r--openwrt/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/openwrt/Makefile b/openwrt/Makefile
index 92137eac20..dfa272120b 100644
--- a/openwrt/Makefile
+++ b/openwrt/Makefile
@@ -166,27 +166,48 @@ $(CONFIG)/mconf:
fi
menuconfig: $(CONFIG)/mconf
+ -touch .config
+ -cp .config .config.test
@$(CONFIG)/mconf $(CONFIG_CONFIG_IN)
+ -./scripts/configtest.pl
config: $(CONFIG)/conf
+ -touch .config
+ -cp .config .config.test
@$(CONFIG)/conf $(CONFIG_CONFIG_IN)
+ -./scripts/configtest.pl
oldconfig: $(CONFIG)/conf
+ -touch .config
+ -cp .config .config.test
@$(CONFIG)/conf -o $(CONFIG_CONFIG_IN)
+ -./scripts/configtest.pl
randconfig: $(CONFIG)/conf
+ -touch .config
+ -cp .config .config.test
@$(CONFIG)/conf -r $(CONFIG_CONFIG_IN)
+ -./scripts/configtest.pl
allyesconfig: $(CONFIG)/conf
#@$(CONFIG)/conf -y $(CONFIG_CONFIG_IN)
#sed -i -e "s/^CONFIG_DEBUG.*/# CONFIG_DEBUG is not set/" .config
+ -touch .config
+ -cp .config .config.test
@$(CONFIG)/conf -o $(CONFIG_CONFIG_IN)
+ -./scripts/configtest.pl
allnoconfig: $(CONFIG)/conf
+ -touch .config
+ -cp .config .config.test
@$(CONFIG)/conf -n $(CONFIG_CONFIG_IN)
+ -./scripts/configtest.pl
defconfig: $(CONFIG)/conf
+ -touch .config
+ -cp .config .config.test
@$(CONFIG)/conf -d $(CONFIG_CONFIG_IN)
+ -./scripts/configtest.pl
#############################################################
#