aboutsummaryrefslogtreecommitdiffstats
path: root/openwrt/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-03-21 16:15:01 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-03-21 16:15:01 +0000
commit5716d7d4f53eca068d9153d4cb353b6c71fd54d3 (patch)
tree8167a4ffe77c882abd4cc35a76a7bf5463e92b30 /openwrt/Makefile
parent92b7f53b6300792b0a1e4057d6b1f66514deda17 (diff)
downloadupstream-5716d7d4f53eca068d9153d4cb353b6c71fd54d3.tar.gz
upstream-5716d7d4f53eca068d9153d4cb353b6c71fd54d3.tar.bz2
upstream-5716d7d4f53eca068d9153d4cb353b6c71fd54d3.zip
check config changes on make world
SVN-Revision: 410
Diffstat (limited to 'openwrt/Makefile')
-rw-r--r--openwrt/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/openwrt/Makefile b/openwrt/Makefile
index 8342bab86b..ef60ff1988 100644
--- a/openwrt/Makefile
+++ b/openwrt/Makefile
@@ -69,9 +69,13 @@ package_install: toolchain
# In this section, we need .config
include .config.cmd
-world: $(DL_DIR) $(BUILD_DIR) target_prepare $(TARGET_DIR) toolchain_install package_install target_install package_index
+world: $(DL_DIR) $(BUILD_DIR) configtest target_prepare $(TARGET_DIR) toolchain_install package_install target_install package_index
-.PHONY: all world clean dirclean distclean image_clean target_clean source target_prepare target_install toolchain_install package_install
+.PHONY: all world clean dirclean distclean image_clean target_clean source target_prepare target_install toolchain_install package_install configtest
+
+configtest:
+ -cp .config .config.test
+ -scripts/configtest.pl
package_index:
(cd $(PACKAGE_DIR); \