aboutsummaryrefslogtreecommitdiffstats
path: root/obsolete-buildroot
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2004-06-04 02:00:59 +0000
committerNed Ludd <solar@gentoo.org>2004-06-04 02:00:59 +0000
commit75caa7e1f0c81423d7f7f0c0f158fd0fc95d5452 (patch)
tree1bc9fa785cde2101b565ecdf10dd03a41669237c /obsolete-buildroot
parent6591d4013f0fb62a90ebbca3b2cf6977c4a55347 (diff)
downloadupstream-75caa7e1f0c81423d7f7f0c0f158fd0fc95d5452.tar.gz
upstream-75caa7e1f0c81423d7f7f0c0f158fd0fc95d5452.tar.bz2
upstream-75caa7e1f0c81423d7f7f0c0f158fd0fc95d5452.zip
patch to allow iproute2 to be cross compiled. could be a sed hack if we wanted/needed.
SVN-Revision: 57
Diffstat (limited to 'obsolete-buildroot')
-rw-r--r--obsolete-buildroot/sources/iproute2-cross-ar-20010824.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/obsolete-buildroot/sources/iproute2-cross-ar-20010824.patch b/obsolete-buildroot/sources/iproute2-cross-ar-20010824.patch
new file mode 100644
index 0000000000..62ed488f9a
--- /dev/null
+++ b/obsolete-buildroot/sources/iproute2-cross-ar-20010824.patch
@@ -0,0 +1,28 @@
+diff -Nrup iproute2.orig/lib/Makefile iproute2/lib/Makefile
+--- iproute2.orig/lib/Makefile 2000-04-16 13:42:52.000000000 -0400
++++ iproute2/lib/Makefile 2004-06-03 19:17:51.000000000 -0400
+@@ -6,10 +6,10 @@ NLOBJ=ll_map.o libnetlink.o
+ all: libnetlink.a libutil.a
+
+ libnetlink.a: $(NLOBJ)
+- ar rcs $@ $(NLOBJ)
++ $(AR) rcs $@ $(NLOBJ)
+
+ libutil.a: $(UTILOBJ) $(ADDLIB)
+- ar rcs $@ $(UTILOBJ) $(ADDLIB)
++ $(AR) rcs $@ $(UTILOBJ) $(ADDLIB)
+
+ clean:
+ rm -f $(NLOBJ) $(UTILOBJ) $(ADDLIB) libnetlink.a libutil.a
+diff -Nrup iproute2.orig/tc/Makefile iproute2/tc/Makefile
+--- iproute2.orig/tc/Makefile 2000-04-16 13:42:53.000000000 -0400
++++ iproute2/tc/Makefile 2004-06-03 19:18:08.000000000 -0400
+@@ -43,7 +43,7 @@ all: libtc.a tc
+ tc: $(TCOBJ) $(LIBNETLINK) $(LIBUTIL) $(TCLIB)
+
+ libtc.a: $(TCLIB)
+- ar rcs $@ $(TCLIB)
++ $(AR) rcs $@ $(TCLIB)
+
+ clean:
+ rm -f $(TCOBJ) $(TCLIB) libtc.a tc