aboutsummaryrefslogtreecommitdiffstats
path: root/obsolete-buildroot/Makefile
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2004-08-20 05:39:59 +0000
committerMike Baker <mbm@openwrt.org>2004-08-20 05:39:59 +0000
commitecfdfb1fec8b4fb1c75b2d14bf8fe2bef2f0504a (patch)
treeb03e6465ab55acd0d11507bcb584626ed5e48c17 /obsolete-buildroot/Makefile
parentaeff585200ecc8dab0b0b089294e33dfa96a0b1a (diff)
downloadupstream-ecfdfb1fec8b4fb1c75b2d14bf8fe2bef2f0504a.tar.gz
upstream-ecfdfb1fec8b4fb1c75b2d14bf8fe2bef2f0504a.tar.bz2
upstream-ecfdfb1fec8b4fb1c75b2d14bf8fe2bef2f0504a.zip
fix zlib; add dropbear ipkg
SVN-Revision: 139
Diffstat (limited to 'obsolete-buildroot/Makefile')
-rw-r--r--obsolete-buildroot/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/obsolete-buildroot/Makefile b/obsolete-buildroot/Makefile
index e534b44c4e..0b67b15394 100644
--- a/obsolete-buildroot/Makefile
+++ b/obsolete-buildroot/Makefile
@@ -97,7 +97,7 @@ INSTALL_LIBGCJ:=false
#############################################################
TARGETS:=host-sed openwrt-code.bin
-PACKAGES:=oidentd iproute2 sched-modules wshaper zlib openssl openssh pppoecd
+PACKAGES:=oidentd iproute2 sched-modules wshaper zlib openssl openssh pppoecd dropbear
#############################################################
#
@@ -192,9 +192,11 @@ world: $(DL_DIR) $(TARGETS_SOURCE) $(BUILD_DIR) $(STAGING_DIR) $(TARGET_DIR) $(T
packages: ipkg-utils $(PACKAGES_IPK)
-@mkdir -p $(BASE_DIR)/packages
- cd $(BASE_DIR)/packages
- -mv $(BUILD_DIR)/*.ipk .
- $(IPKG_MAKE_INDEX) . > Packages
+ { \
+ cd $(BASE_DIR)/packages; \
+ mv $(BUILD_DIR)/*.ipk .; \
+ $(IPKG_MAKE_INDEX) . > Packages; \
+ }
@echo "ALL DONE."
.PHONY: all world clean dirclean distclean source $(TARGETS) \