aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-04-03 15:22:26 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-04-03 15:22:26 +0000
commitfa6d92f407d3fd4b942276da79f518296ad46046 (patch)
treedf5a1236cd161b3957385b9b07fd8bd079e6c027 /include
parentfe46689f104b5d0363f06a286a215fd98a3e6d72 (diff)
downloadupstream-fa6d92f407d3fd4b942276da79f518296ad46046.tar.gz
upstream-fa6d92f407d3fd4b942276da79f518296ad46046.tar.bz2
upstream-fa6d92f407d3fd4b942276da79f518296ad46046.zip
image.mk: export the FILESYSTEM variable to build commands
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 45251
Diffstat (limited to 'include')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 8d201447fc..3ff8768a6a 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -353,7 +353,7 @@ define Device/ExportVar
$(1) : $(2):=$$($(2))
endef
-Device/Export = $(foreach var,$(DEVICE_VARS) KERNEL KERNEL_INITRAMFS,$(call Device/ExportVar,$(1),$(var)))
+Device/Export = $(foreach var,$(DEVICE_VARS) KERNEL KERNEL_INITRAMFS FILESYSTEM,$(call Device/ExportVar,$(1),$(var)))
define Device/Check
_TARGET = $$(if $$(filter $(PROFILE),$$(PROFILES)),install,install-disabled)