aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2021-02-15 18:46:11 +0100
committerFelix Fietkau <nbd@nbd.name>2021-02-15 18:47:19 +0100
commitf696cd3df3669a1a0a247623b549afeed718e207 (patch)
tree33fe22650ca2a09b483561e88ca53d1e63de264e /include
parent0a497c4640a05bafa7e8115620438bfd4967a973 (diff)
downloadupstream-f696cd3df3669a1a0a247623b549afeed718e207.tar.gz
upstream-f696cd3df3669a1a0a247623b549afeed718e207.tar.bz2
upstream-f696cd3df3669a1a0a247623b549afeed718e207.zip
build: add support for patching libtool to include ABI version in soname
Use the version from PKG_ABI_VERSION Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include')
-rw-r--r--include/autotools.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/include/autotools.mk b/include/autotools.mk
index ec67c844f7..4b48b38992 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -62,6 +62,12 @@ define patch_libtool
);
endef
+define set_libtool_abiver
+ sed -i \
+ -e 's,^soname_spec=.*,soname_spec="\\$$$${libname}\\$$$${shared_ext}.$(PKG_ABI_VERSION)",' \
+ -e 's,^library_names_spec=.*,library_names_spec="\\$$$${libname}\\$$$${shared_ext}.$(PKG_ABI_VERSION) \\$$$${libname}\\$$$${shared_ext}",' \
+ $(PKG_BUILD_DIR)/libtool
+endef
PKG_LIBTOOL_PATHS?=$(CONFIGURE_PATH)
PKG_AUTOMAKE_PATHS?=$(CONFIGURE_PATH)
@@ -110,6 +116,10 @@ ifneq ($(filter libtool,$(PKG_FIXUP)),)
endif
endif
+ifneq ($(filter libtool-abiver,$(PKG_FIXUP)),)
+ Hooks/Configure/Post += set_libtool_abiver
+endif
+
ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
PKG_BUILD_DEPENDS += libtool gettext libiconv
ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)