aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorBas Mevissen <abuse@basmevissen.nl>2021-04-20 01:08:19 +0200
committerBaptiste Jonglez <git@bitsofnetworks.org>2021-05-08 12:43:45 +0200
commitf68c9474acf9a65b5a9538db8e45c173462487e3 (patch)
treeb18cf8efc4639290cf5a1872637fc0f487f9fb08 /include
parent2eda042d553c23590c9d6ade8a1a17ffcfb4be7c (diff)
downloadupstream-f68c9474acf9a65b5a9538db8e45c173462487e3.tar.gz
upstream-f68c9474acf9a65b5a9538db8e45c173462487e3.tar.bz2
upstream-f68c9474acf9a65b5a9538db8e45c173462487e3.zip
Extend checks on build prerequisites for building OpenWRT core
OpenWRT requires a number of Perl modules to be installed. It wasn't checking on all of them. This patch adds checks for Perl FindBin, File::Copy, File::Compare and Thread::Queue modules. Failing to install these, will have the build break at some point. By adding these to the prereq-build.mk script, they are checked on forehand. Tested on a Fedora 33 and 34 (beta) that was freshly installed. Fedora appears to break up Perl modules into small packages that need to be installed for the build to succeed. Signed-off-by: Bas Mevissen <abuse@basmevissen.nl>
Diffstat (limited to 'include')
-rw-r--r--include/prereq-build.mk13
1 files changed, 12 insertions, 1 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 0375ef6861..8adf0d03dd 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -65,11 +65,22 @@ $(eval $(call TestHostCommand,perl-data-dumper, \
Please install the Perl Data::Dumper module, \
perl -MData::Dumper -e 1))
+$(eval $(call TestHostCommand,perl-findbin, \
+ Please install the Perl FindBin module, \
+ perl -MFindBin -e 1))
+
+$(eval $(call TestHostCommand,perl-file-copy, \
+ Please install the Perl File::Copy module, \
+ perl -MFile::Copy -e 1))
+
+$(eval $(call TestHostCommand,perl-file-compare, \
+ Please install the Perl File::Compare module, \
+ perl -MFile::Compare -e 1))
+
$(eval $(call TestHostCommand,perl-thread-queue, \
Please install the Perl Thread::Queue module, \
perl -MThread::Queue -e 1))
-
$(eval $(call SetupHostCommand,tar,Please install GNU 'tar', \
gtar --version 2>&1 | grep GNU, \
gnutar --version 2>&1 | grep GNU, \