aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2016-11-24 13:50:02 +0800
committerFelix Fietkau <nbd@nbd.name>2016-11-24 12:53:19 +0100
commitf66cb6f810e55016167086bd96310fc14c1e6362 (patch)
tree0b8507b594fd2c244cc0b60ca222f29da5abb5a3 /include
parent49856a4bb5818146d9cf951cb65a0903d3b38fd4 (diff)
downloadupstream-f66cb6f810e55016167086bd96310fc14c1e6362.tar.gz
upstream-f66cb6f810e55016167086bd96310fc14c1e6362.tar.bz2
upstream-f66cb6f810e55016167086bd96310fc14c1e6362.zip
build: find_md5: ignore non-existent files or directories
Targets like malta can have no patches/ directory available and this commit tries quash "no such file or directory" messages from `find` Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'include')
-rw-r--r--include/depends.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/depends.mk b/include/depends.mk
index 53e5b1e5b2..7135e52c0f 100644
--- a/include/depends.mk
+++ b/include/depends.mk
@@ -13,7 +13,7 @@
DEP_FINDPARAMS := -x "*/.svn*" -x ".*" -x "*:*" -x "*\!*" -x "* *" -x "*\\\#*" -x "*/.*_check" -x "*/.*.swp"
-find_md5=$(SH_FUNC) find $(1) -type f $(patsubst -x,-and -not -path,$(DEP_FINDPARAMS) $(2)) | md5s
+find_md5=$(SH_FUNC) find $(wildcard $(1)) -type f $(patsubst -x,-and -not -path,$(DEP_FINDPARAMS) $(2)) | md5s
define rdep
.PRECIOUS: $(2)