aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-10-29 00:12:16 -0700
committerPaul Spooren <mail@aparcar.org>2020-11-24 23:40:39 -1000
commite224a9a98fac9e86e7cf77446c2d95777021a72e (patch)
treed0e069deb5f617ed5ef6941990377dbbf987bbb2 /include
parent3c0059773c107c662b8a785d021f91aa441d3576 (diff)
downloadupstream-e224a9a98fac9e86e7cf77446c2d95777021a72e.tar.gz
upstream-e224a9a98fac9e86e7cf77446c2d95777021a72e.tar.bz2
upstream-e224a9a98fac9e86e7cf77446c2d95777021a72e.zip
prereq-build: add python 3.9 support
Fixes unmet dependency issue. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'include')
-rw-r--r--include/prereq-build.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 8181812599..e7314b253b 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -149,6 +149,7 @@ $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
$(eval $(call CleanupPython2))
$(eval $(call SetupHostCommand,python,Please install Python >= 3.5, \
+ python3.9 -V 2>&1 | grep 'Python 3', \
python3.8 -V 2>&1 | grep 'Python 3', \
python3.7 -V 2>&1 | grep 'Python 3', \
python3.6 -V 2>&1 | grep 'Python 3', \
@@ -156,6 +157,7 @@ $(eval $(call SetupHostCommand,python,Please install Python >= 3.5, \
python3 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?'))
$(eval $(call SetupHostCommand,python3,Please install Python >= 3.5, \
+ python3.9 -V 2>&1 | grep 'Python 3', \
python3.8 -V 2>&1 | grep 'Python 3', \
python3.7 -V 2>&1 | grep 'Python 3', \
python3.6 -V 2>&1 | grep 'Python 3', \