aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2021-03-01 14:07:33 +0000
committerDaniel Golle <daniel@makrotopia.org>2021-03-01 19:33:46 +0000
commitded54ae19622423b5e3e30c7ee59316af01f8bf3 (patch)
treef5b00593c76a67d638689b5dae5b3107c80f79d1 /include
parent7a7b2fd809809fbd7045bd3dad4fc896a6fef06f (diff)
downloadupstream-ded54ae19622423b5e3e30c7ee59316af01f8bf3.tar.gz
upstream-ded54ae19622423b5e3e30c7ee59316af01f8bf3.tar.bz2
upstream-ded54ae19622423b5e3e30c7ee59316af01f8bf3.zip
mediatek: mt7622: bpi-r64: simplify eMMC install procedure
Write everything needed for eMMC install into the gaps between partitions on SD card. In that way, installation to eMMC only needs the SD card, no additional files need to be loaded via TFTP any more. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'include')
-rw-r--r--include/image-commands.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 10b23e027b..31690883fd 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -27,6 +27,10 @@ define Build/append-kernel
dd if=$(IMAGE_KERNEL) >> $@
endef
+define Build/append-image
+ dd if=$(BIN_DIR)/$(IMG_PREFIX)$(if $(PROFILE_SANITIZED),-$(PROFILE_SANITIZED))-$(1) >> $@
+endef
+
compat_version=$(if $(DEVICE_COMPAT_VERSION),$(DEVICE_COMPAT_VERSION),1.0)
json_quote=$(subst ','\'',$(subst ",\",$(1)))
#")')