aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2021-04-23 23:05:54 +0100
committerDaniel Golle <daniel@makrotopia.org>2021-04-23 23:16:49 +0100
commitde4b29dab987c5c1288558c3ca7e1edcd95920e0 (patch)
tree50bb1d7f392f6343638bc1dab8ff0d1b59aa14db /include
parent95ac3f82c6914505b01b01ab819e02d091835598 (diff)
downloadupstream-de4b29dab987c5c1288558c3ca7e1edcd95920e0.tar.gz
upstream-de4b29dab987c5c1288558c3ca7e1edcd95920e0.tar.bz2
upstream-de4b29dab987c5c1288558c3ca7e1edcd95920e0.zip
image: introduce 'append-image-stage' build command
Similar to 'append-image' this new command appends an existing binary. 'append-image-stage' also makes a copy of that binary and keeps it in $(STAGING_DIR_IMAGE). When called from within the ImageBuilder, this copy is used instead of expecting the binary to be present. This is useful for artifacts which include the initramfs/recovery image which is usually not included in the ImageBuilder. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'include')
-rw-r--r--include/image-commands.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 2c56ed8d1d..4c9075c35b 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -31,6 +31,18 @@ define Build/append-image
dd if=$(BIN_DIR)/$(DEVICE_IMG_PREFIX)-$(1) >> $@
endef
+ifdef IB
+define Build/append-image-stage
+ dd if=$(STAGING_DIR_IMAGE)/$(DEVICE_IMG_PREFIX)-$(1) >> $@
+endef
+else
+define Build/append-image-stage
+ dd if=$(BIN_DIR)/$(DEVICE_IMG_PREFIX)-$(1) of=$(STAGING_DIR_IMAGE)/$(DEVICE_IMG_PREFIX)-$(1)
+ dd if=$(BIN_DIR)/$(DEVICE_IMG_PREFIX)-$(1) >> $@
+endef
+endif
+
+
compat_version=$(if $(DEVICE_COMPAT_VERSION),$(DEVICE_COMPAT_VERSION),1.0)
json_quote=$(subst ','\'',$(subst ",\",$(1)))
#")')