aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2019-06-09 06:00:47 +0800
committerPetr Štetiar <ynezz@true.cz>2020-03-01 21:35:59 +0100
commitdddcff25501ddd07546be09758fde2a6b56116ca (patch)
treef9046baf7e6be2c91e19baff6cb38c613e78d60f /include
parent12020f8a95d21547bd7d7fd1fef9cdecf2892803 (diff)
downloadupstream-dddcff25501ddd07546be09758fde2a6b56116ca.tar.gz
upstream-dddcff25501ddd07546be09758fde2a6b56116ca.tar.bz2
upstream-dddcff25501ddd07546be09758fde2a6b56116ca.zip
build: Remove STAGING_DIR_HOST references for InstallDev/UninstallDev
Build/InstallDev no longer places a file list in $(STAGING_DIR_HOST)/packages; this change removes the creation of $(STAGING_DIR_HOST)/packages and the attempted removal of a STAGING_DIR_HOST file list during package clean. This also changes the host directory passed to Build/UninstallDev from $(STAGING_DIR_HOST) to $(STAGING_DIR)/host, to match the directory passed to Build/InstallDev. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'include')
-rw-r--r--include/package.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/include/package.mk b/include/package.mk
index c541f6edf7..0575692742 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -223,7 +223,7 @@ define Build/CoreTargets
$(STAMP_INSTALLED) : export PATH=$$(TARGET_PATH_PKG)
$(STAMP_INSTALLED): $(STAMP_BUILT)
rm -rf $(TMP_DIR)/stage-$(PKG_DIR_NAME)
- mkdir -p $(TMP_DIR)/stage-$(PKG_DIR_NAME)/host $(STAGING_DIR)/packages $(STAGING_DIR_HOST)/packages
+ mkdir -p $(TMP_DIR)/stage-$(PKG_DIR_NAME)/host $(STAGING_DIR)/packages
$(foreach hook,$(Hooks/InstallDev/Pre),\
$(call $(hook),$(TMP_DIR)/stage-$(PKG_DIR_NAME),$(TMP_DIR)/stage-$(PKG_DIR_NAME)/host)$(sep)\
)
@@ -342,9 +342,9 @@ clean-build: $(if $(wildcard $(PKG_BUILD_DIR)/.autoremove),force-clean-build)
clean: force-clean-build
$(CleanStaging)
- $(call Build/UninstallDev,$(STAGING_DIR),$(STAGING_DIR_HOST))
+ $(call Build/UninstallDev,$(STAGING_DIR),$(STAGING_DIR)/host)
$(Build/Clean)
- rm -f $(STAGING_DIR)/packages/$(STAGING_FILES_LIST) $(STAGING_DIR_HOST)/packages/$(STAGING_FILES_LIST)
+ rm -f $(STAGING_DIR)/packages/$(STAGING_FILES_LIST)
dist:
$(Build/Dist)