aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-11-24 13:55:40 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-11-24 13:55:40 +0000
commitd55a046c487d68af972477723fffa0f08113350f (patch)
tree9e0b787a2610ed25229e89e6d04bb11790c1ff43 /include
parentcafe76e10361d2ca31edfb2017378b92c6e3b5b8 (diff)
downloadupstream-d55a046c487d68af972477723fffa0f08113350f.tar.gz
upstream-d55a046c487d68af972477723fffa0f08113350f.tar.bz2
upstream-d55a046c487d68af972477723fffa0f08113350f.zip
ar71xx: the squashfs-4k images are unreliable in some builds. add 4k, 8k padding to the generic squashfs images and use them on 4k devices as well
SVN-Revision: 18526
Diffstat (limited to 'include')
-rw-r--r--include/image.mk12
1 files changed, 8 insertions, 4 deletions
diff --git a/include/image.mk b/include/image.mk
index a722086a07..d75ca3c30f 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -40,13 +40,17 @@ define add_jffs2_mark
echo -ne '\xde\xad\xc0\xde' >> $(1)
endef
-# pad to 64k and add jffs2 end-of-filesystem mark
-# do this twice to make sure that this works with 128k blocksize as well
+# pad to 4k, 8k, 64k, 128k and add jffs2 end-of-filesystem mark
define prepare_generic_squashfs
- dd if=$(1) of=$(KDIR)/tmpfile.1 bs=64k conv=sync
+ dd if=$(1) of=$(KDIR)/tmpfile.0 bs=4k conv=sync
+ $(call add_jffs2_mark,$(KDIR)/tmpfile.0)
+ dd if=$(KDIR)/tmpfile.0 of=$(KDIR)/tmpfile.1 bs=4k conv=sync
$(call add_jffs2_mark,$(KDIR)/tmpfile.1)
- dd of=$(1) if=$(KDIR)/tmpfile.1 bs=64k conv=sync
+ dd if=$(KDIR)/tmpfile.1 of=$(KDIR)/tmpfile.2 bs=64k conv=sync
+ $(call add_jffs2_mark,$(KDIR)/tmpfile.2)
+ dd if=$(KDIR)/tmpfile.2 of=$(1) bs=64k conv=sync
$(call add_jffs2_mark,$(1))
+ rm -f $(KDIR)/tmpfile.*
endef
ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)