aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-23 14:52:50 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-23 14:52:50 +0000
commitd398dc030991a13184fda482e38e201e308effa3 (patch)
tree549d8d5ca10693c189d0fef9f91ff34049b825b2 /include
parenta780bac5cc3f0ac9203b0d4489ebf76ba3d0d7cd (diff)
downloadupstream-d398dc030991a13184fda482e38e201e308effa3.tar.gz
upstream-d398dc030991a13184fda482e38e201e308effa3.tar.bz2
upstream-d398dc030991a13184fda482e38e201e308effa3.zip
always dereference symbolic links when copying kernel modules into the packaging directory (fixes alsa build, patch from #1392)
SVN-Revision: 6350
Diffstat (limited to 'include')
-rw-r--r--include/kernel.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 1f34f00ca4..4cf0e7a72d 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -99,7 +99,7 @@ define KernelPackage
ifneq ($(strip $(FILES)),)
define Package/kmod-$(1)/install
mkdir -p $$(1)/lib/modules/$(LINUX_VERSION)
- $(CP) $$(FILES) $$(1)/lib/modules/$(LINUX_VERSION)/
+ $(CP) -L $$(FILES) $$(1)/lib/modules/$(LINUX_VERSION)/
$(call ModuleAutoLoad,$(1),$$(1),$(AUTOLOAD))
$(call KernelPackage/$(1)/install,$$(1))
endef