aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-05-29 13:41:21 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-05-29 13:41:21 +0000
commitd1372992c4a3337be4983e2b75dea6b49216e6fe (patch)
treed8db650aa5834fda0d13382dc4349d2d6779931e /include
parentddf120fc0394d15dc3c012f1f8fac2e8a89c43cd (diff)
downloadupstream-d1372992c4a3337be4983e2b75dea6b49216e6fe.tar.gz
upstream-d1372992c4a3337be4983e2b75dea6b49216e6fe.tar.bz2
upstream-d1372992c4a3337be4983e2b75dea6b49216e6fe.zip
build: in new image building code, do not rebuild kernel images in the image builder
Some kernel images need to be wrapped in a loader, which cannot be built without a working toolchain. Also, this speeds up the image builder run. Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 45836
Diffstat (limited to 'include')
-rw-r--r--include/image.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 8e8ddc29ac..051f0f7e53 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -397,10 +397,15 @@ define Device/Build/kernel
$$(_TARGET): $$(if $$(KERNEL_INSTALL),$(BIN_DIR)/$$(KERNEL_IMAGE))
$(BIN_DIR)/$$(KERNEL_IMAGE): $(KDIR)/$$(KERNEL_IMAGE)
cp $$^ $$@
- $(KDIR)/$$(KERNEL_IMAGE): $(KDIR)/$$(KERNEL_NAME)
+ ifndef IB
+ ifdef CONFIG_IB
+ install: $(KDIR)/$$(KERNEL_IMAGE)
+ endif
+ $(KDIR)/$$(KERNEL_IMAGE): $(KDIR)/$$(KERNEL_NAME)
@rm -f $$@
$$(call concat_cmd,$$(KERNEL))
$$(if $$(KERNEL_SIZE),$$(call Device/Build/check_size,$$(KERNEL_SIZE)))
+ endif
endef
define Device/Build/image