aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-11-08 18:40:37 +0100
committerFelix Fietkau <nbd@nbd.name>2018-02-05 10:15:53 +0100
commitcde71a543c629f63e6f01850fd8b6f3f94cdd25d (patch)
tree61a463012d3958e88e256b27f43e939dfd0b03a0 /include
parentecc347dd6e175b23590dc4ddb91344397d3eeb4d (diff)
downloadupstream-cde71a543c629f63e6f01850fd8b6f3f94cdd25d.tar.gz
upstream-cde71a543c629f63e6f01850fd8b6f3f94cdd25d.tar.bz2
upstream-cde71a543c629f63e6f01850fd8b6f3f94cdd25d.zip
build: replace uses of OpenWrt with $(VERSION_DIST)
This makes the distribution name more configurable. Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include')
-rw-r--r--include/image-commands.mk6
-rw-r--r--include/image.mk2
2 files changed, 4 insertions, 4 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index bcc1256df8..adef8f2759 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -7,7 +7,7 @@ define Build/uImage
mkimage -A $(LINUX_KARCH) \
-O linux -T kernel \
-C $(1) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
- -n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) OpenWrt Linux-$(LINUX_VERSION))' -d $@ $@.new
+ -n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) Linux-$(LINUX_VERSION))' -d $@ $@.new
mv $@.new $@
endef
@@ -60,7 +60,7 @@ endef
define Build/netgear-dni
$(STAGING_DIR_HOST)/bin/mkdniimg \
- -B $(NETGEAR_BOARD_ID) -v OpenWrt.$(REVISION) \
+ -B $(NETGEAR_BOARD_ID) -v $(VERSION_DIST).$(REVISION) \
$(if $(NETGEAR_HW_ID),-H $(NETGEAR_HW_ID)) \
-r "$(1)" \
-i $@ -o $@.new
@@ -83,7 +83,7 @@ define Build/append-uImage-fakeroot-hdr
rm -f $@.fakeroot
$(STAGING_DIR_HOST)/bin/mkimage \
-A $(LINUX_KARCH) -O linux -T filesystem -C none \
- -n '$(call toupper,$(LINUX_KARCH)) OpenWrt fakeroot' \
+ -n '$(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) fakeroot' \
-s \
$@.fakeroot
cat $@.fakeroot >> $@
diff --git a/include/image.mk b/include/image.mk
index af01951b49..723e4f1897 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -136,7 +136,7 @@ endef
define Image/BuildKernel/MkuImage
mkimage -A $(ARCH) -O linux -T kernel -C $(1) -a $(2) -e $(3) \
- -n '$(call toupper,$(ARCH)) OpenWrt Linux-$(LINUX_VERSION)' -d $(4) $(5)
+ -n '$(call toupper,$(ARCH)) $(VERSION_DIST) Linux-$(LINUX_VERSION)' -d $(4) $(5)
endef
define Image/BuildKernel/MkFIT