aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-09-03 06:46:44 +0000
committerNicolas Thill <nico@openwrt.org>2007-09-03 06:46:44 +0000
commitcc9d43a53df04cfe2df7ea023e64da95e7a0b470 (patch)
tree5914d1dd2e09d7d49618b597538ce92e7c85344f /include
parent81555924a2dd5b603080a0e72259cadd649be6c2 (diff)
downloadupstream-cc9d43a53df04cfe2df7ea023e64da95e7a0b470.tar.gz
upstream-cc9d43a53df04cfe2df7ea023e64da95e7a0b470.tar.bz2
upstream-cc9d43a53df04cfe2df7ea023e64da95e7a0b470.zip
move ipkg related vars from ./rules.mk to ./include/package-ipkg.mk
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8581 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/package-ipkg.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index cc9a780147..452ae5032d 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -5,6 +5,18 @@
# See /LICENSE for more information.
#
+# where to build (and put) .ipk packages
+IPKG:= \
+ IPKG_TMP=$(TMP_DIR)/ipkg \
+ IPKG_INSTROOT=$(TARGET_DIR) \
+ IPKG_CONF_DIR=$(STAGING_DIR)/etc \
+ IPKG_OFFLINE_ROOT=$(TARGET_DIR) \
+ $(SCRIPT_DIR)/ipkg -force-defaults -force-depends
+
+# invoke ipkg-build with some default options
+IPKG_BUILD:= \
+ ipkg-build -c -o 0 -g 0
+
define BuildIPKGVariable
$(call shexport,Package/$(1)/$(2))
$(1)_COMMANDS += var2file "$(call shvar,Package/$(1)/$(2))" $(2);