aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorMirko Vogt <mirko-openwrt@nanl.de>2017-01-18 14:36:45 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-18 21:03:26 +0100
commitc99f8815680fb4abf42cbb2e9d1a909f8f373b02 (patch)
tree5f6aa9cd52cdc71d020ab706efc9267155ab0fb4 /include
parent3d71786154fbb3fcfbd652115f3e75db3f729941 (diff)
downloadupstream-c99f8815680fb4abf42cbb2e9d1a909f8f373b02.tar.gz
upstream-c99f8815680fb4abf42cbb2e9d1a909f8f373b02.tar.bz2
upstream-c99f8815680fb4abf42cbb2e9d1a909f8f373b02.zip
git-kernel: $(SUBDIR) should always be $(LINUX_VERSION)
Before SUBDIR was set to $(PATCHVER) which may or may not include the minor version number of the linux kernel version. Usually it doesn't. So the git-clone'd linux kernel was packed without the minor version number taken into account, which broke further processing, as it expected the extracted dir being named linux-$(LINUX_VERSION) (=with minor version) rather than linux-$(PATCHVER) (=without minor version). Changing SUBDIR to $(LINUX_VERSION) creates consistent behaviour here. Signed-off-by: Mirko Vogt <mirko-openwrt@nanl.de>
Diffstat (limited to 'include')
-rw-r--r--include/kernel-build.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/kernel-build.mk b/include/kernel-build.mk
index 2bf47b17e4..32da94babc 100644
--- a/include/kernel-build.mk
+++ b/include/kernel-build.mk
@@ -60,7 +60,7 @@ define Download/git-kernel
PROTO:=git
VERSION:=$(CONFIG_KERNEL_GIT_BRANCH)
FILE:=$(LINUX_SOURCE)
- SUBDIR:=linux-$(KERNEL_PATCHVER)
+ SUBDIR:=linux-$(LINUX_VERSION)
OPTS:=$(KERNEL_GIT_OPTS)
endef