aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2021-04-24 12:12:09 +0100
committerDaniel Golle <daniel@makrotopia.org>2021-04-24 12:19:06 +0100
commitc7a5a093efd0725ef170c6dacd414044020233d9 (patch)
treee327ca6c9894a29f7d862af2cf1dc59a60870c23 /include
parent210916c9e6797e4e520970bafba12e49e98dc834 (diff)
downloadupstream-c7a5a093efd0725ef170c6dacd414044020233d9.tar.gz
upstream-c7a5a093efd0725ef170c6dacd414044020233d9.tar.bz2
upstream-c7a5a093efd0725ef170c6dacd414044020233d9.zip
image: use portable filename in 'append-image-stage'
The 'append-image-stage' command doesn't work when setting the EXTRA_IMAGE_NAME option of the ImageBuilder as in that case DEVICE_IMG_PREFIX is modified and no longer matches the value it had in buildroot. Choose a filename independent of DEVICE_IMG_PREFIX for images staged using 'append-image-stage' to fix that. Fixes: de4b29dab9 ("image: introduce 'append-image-stage' build command") Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'include')
-rw-r--r--include/image-commands.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 4c9075c35b..9702d029d7 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -33,11 +33,11 @@ endef
ifdef IB
define Build/append-image-stage
- dd if=$(STAGING_DIR_IMAGE)/$(DEVICE_IMG_PREFIX)-$(1) >> $@
+ dd if=$(STAGING_DIR_IMAGE)/$(BOARD)$(if $(SUBTARGET),-$(SUBTARGET))-$(DEVICE_NAME)-$(1) >> $@
endef
else
define Build/append-image-stage
- dd if=$(BIN_DIR)/$(DEVICE_IMG_PREFIX)-$(1) of=$(STAGING_DIR_IMAGE)/$(DEVICE_IMG_PREFIX)-$(1)
+ dd if=$(BIN_DIR)/$(DEVICE_IMG_PREFIX)-$(1) of=$(STAGING_DIR_IMAGE)/$(BOARD)$(if $(SUBTARGET),-$(SUBTARGET))-$(DEVICE_NAME)-$(1)
dd if=$(BIN_DIR)/$(DEVICE_IMG_PREFIX)-$(1) >> $@
endef
endif