aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-06 16:49:52 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-07 17:50:54 +0100
commitc2e6ca26e52d1675ed1d9c7edbde257817806176 (patch)
tree1443453c05c1973d0ce7ec874b9df5202bbe9f8b /include
parentb18f75c3d80105182eeaa13e887a9dff8bc33e82 (diff)
downloadupstream-c2e6ca26e52d1675ed1d9c7edbde257817806176.tar.gz
upstream-c2e6ca26e52d1675ed1d9c7edbde257817806176.tar.bz2
upstream-c2e6ca26e52d1675ed1d9c7edbde257817806176.zip
build: add image command for calling kernel2minor
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include')
-rw-r--r--include/image-commands.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 083a389031..a7acd0ee67 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -190,3 +190,8 @@ metadata_json = \
define Build/append-metadata
$(if $(SUPPORTED_DEVICES),echo $(call metadata_json,$(SUPPORTED_DEVICES)) | fwtool -I - $@)
endef
+
+define Build/kernel2minor
+ kernel2minor -k $@ -r $@.new $(1)
+ mv $@.new $@
+endef