aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2021-03-02 01:41:00 +0000
committerDaniel Golle <daniel@makrotopia.org>2021-03-02 01:41:31 +0000
commitbb98ddc47b5d7c91428bfe0ca0f469a8f518f575 (patch)
treeb00e628fc6d26ea28f0a0edb57b4a83f85f73681 /include
parenta3288c35efbd5e2a97aafffc23ae8703ed394801 (diff)
downloadupstream-bb98ddc47b5d7c91428bfe0ca0f469a8f518f575.tar.gz
upstream-bb98ddc47b5d7c91428bfe0ca0f469a8f518f575.tar.bz2
upstream-bb98ddc47b5d7c91428bfe0ca0f469a8f518f575.zip
mediatek: mt7622: make sure image generation can run in parallel
The previous approach of referencing artifacts in follow-up artifacts can't work with parallel builds in the current way image.mk is built. Refactor things so this is not needed. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'include')
-rw-r--r--include/image-commands.mk4
1 files changed, 0 insertions, 4 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 31690883fd..10b23e027b 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -27,10 +27,6 @@ define Build/append-kernel
dd if=$(IMAGE_KERNEL) >> $@
endef
-define Build/append-image
- dd if=$(BIN_DIR)/$(IMG_PREFIX)$(if $(PROFILE_SANITIZED),-$(PROFILE_SANITIZED))-$(1) >> $@
-endef
-
compat_version=$(if $(DEVICE_COMPAT_VERSION),$(DEVICE_COMPAT_VERSION),1.0)
json_quote=$(subst ','\'',$(subst ",\",$(1)))
#")')