aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2021-06-08 19:30:12 +0200
committerDavid Bauer <mail@david-bauer.net>2021-06-08 22:53:14 +0200
commitbb749e49a6e149f681a058b3d7e45fd8d4f79305 (patch)
tree3fa961906daa0a93f0f37a46cbc0e220a05d054b /include
parent1aa80ce3931736f1020f69f486a815c2b2575d19 (diff)
downloadupstream-bb749e49a6e149f681a058b3d7e45fd8d4f79305.tar.gz
upstream-bb749e49a6e149f681a058b3d7e45fd8d4f79305.tar.bz2
upstream-bb749e49a6e149f681a058b3d7e45fd8d4f79305.zip
build: fix build for devices without initramfs
Don't attempt to copy initramfs images for devices which do not output an initramfs image. This was breaking builds for mpc85xx-p1010 since mid-march. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'include')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 0d0e3eaba1..a7473abe68 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -478,7 +478,7 @@ define Device/Build/initramfs
$$(if $$(CONFIG_JSON_OVERVIEW_IMAGE_INFO), $(BUILD_DIR)/json_info_files/$$(KERNEL_INITRAMFS_IMAGE).json,))
$(KDIR)/$$(KERNEL_INITRAMFS_NAME):: image_prepare
- $(1)-images: $(BIN_DIR)/$$(KERNEL_INITRAMFS_IMAGE)
+ $(1)-images: $$(if $$(KERNEL_INITRAMFS),$(BIN_DIR)/$$(KERNEL_INITRAMFS_IMAGE))
$(BIN_DIR)/$$(KERNEL_INITRAMFS_IMAGE): $(KDIR)/tmp/$$(KERNEL_INITRAMFS_IMAGE)
cp $$^ $$@