aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorJoseph C. Lehner <joseph.c.lehner@gmail.com>2017-01-23 14:40:10 +0100
committerMathias Kresin <dev@kresin.me>2017-01-27 11:10:10 +0100
commitaeba0fe466b5e850d0cf0697fc120070230d7831 (patch)
tree01969177a4171caadee82f0ef7c0b4d215d318fe /include
parent99eb6f97e519d5ab7870345ef0ae4680d1c92166 (diff)
downloadupstream-aeba0fe466b5e850d0cf0697fc120070230d7831.tar.gz
upstream-aeba0fe466b5e850d0cf0697fc120070230d7831.tar.bz2
upstream-aeba0fe466b5e850d0cf0697fc120070230d7831.zip
build: move append-file to image-commands.mk
Move it append-file to image-commands.mk so that it can used by other targets as well. Signed-off-by: Joseph C. Lehner <joseph.c.lehner@gmail.com>
Diffstat (limited to 'include')
-rw-r--r--include/image-commands.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 04fa853fbb..e0f2918a38 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -110,6 +110,10 @@ define Build/append-rootfs
dd if=$(IMAGE_ROOTFS) >> $@
endef
+define Build/append-file
+ cat "$(1)" >> "$@"
+endef
+
define Build/append-ubi
sh $(TOPDIR)/scripts/ubinize-image.sh \
$(if $(UBOOTENV_IN_UBI),--uboot-env) \