aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorRobert Marko <robert.marko@sartura.hr>2021-03-04 12:37:22 +0100
committerDaniel Golle <daniel@makrotopia.org>2021-03-05 15:45:33 +0000
commit9f714398e060c6338fbfad44cdbfa8c940dbb84b (patch)
tree02fb108aec8f10957ac431f545f8b3db7271392d /include
parent5ec60cbe9d94b925393bea2a54bdaf062a28fece (diff)
downloadupstream-9f714398e060c6338fbfad44cdbfa8c940dbb84b.tar.gz
upstream-9f714398e060c6338fbfad44cdbfa8c940dbb84b.tar.bz2
upstream-9f714398e060c6338fbfad44cdbfa8c940dbb84b.zip
build: use config-1 instead of config@1 as default
U-boot will reject all nodes with @ since commit: https://gitlab.denx.de/u-boot/u-boot/-/commit/79af75f7776fc20b0d7eb6afe1e27c00fdb4b9b4 This will cause the OpenWrt images to fail booting, to rectify use the config-1 as default. Signed-off-by: Robert Marko <robert.marko@sartura.hr>
Diffstat (limited to 'include')
-rw-r--r--include/image-commands.mk2
-rw-r--r--include/image.mk2
2 files changed, 2 insertions, 2 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 10b23e027b..daa01a3d09 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -214,7 +214,7 @@ define Build/fit
-i $(KERNEL_BUILD_DIR)/initrd.cpio$(strip $(call Build/initrd_compression)))) \
-a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
$(if $(DEVICE_FDT_NUM),-n $(DEVICE_FDT_NUM)) \
- -c $(if $(DEVICE_DTS_CONFIG),$(DEVICE_DTS_CONFIG),"config@1") \
+ -c $(if $(DEVICE_DTS_CONFIG),$(DEVICE_DTS_CONFIG),"config-1") \
-A $(LINUX_KARCH) -v $(LINUX_VERSION)
PATH=$(LINUX_DIR)/scripts/dtc:$(PATH) mkimage $(if $(findstring external,$(word 3,$(1))),\
-E -B 0x1000 $(if $(findstring static,$(word 3,$(1))),-p 0x1000)) -f $@.its $@.new
diff --git a/include/image.mk b/include/image.mk
index 993de5ff53..cae3e73438 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -139,7 +139,7 @@ endef
define Image/BuildKernel/MkFIT
$(TOPDIR)/scripts/mkits.sh \
-D $(1) -o $(KDIR)/fit-$(1).its -k $(2) $(if $(3),-d $(3)) -C $(4) -a $(5) -e $(6) \
- -c $(if $(DEVICE_DTS_CONFIG),$(DEVICE_DTS_CONFIG),"config@1") \
+ -c $(if $(DEVICE_DTS_CONFIG),$(DEVICE_DTS_CONFIG),"config-1") \
-A $(LINUX_KARCH) -v $(LINUX_VERSION)
PATH=$(LINUX_DIR)/scripts/dtc:$(PATH) mkimage -f $(KDIR)/fit-$(1).its $(KDIR)/fit-$(1)$(7).itb
endef