aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2021-03-24 13:34:13 +0000
committerDaniel Golle <daniel@makrotopia.org>2021-03-24 15:27:48 +0000
commit8f89b1ab0fef81c85925c88e99a557e91e575aa3 (patch)
tree9a2cfc2925ac94d34ce94f3d57c3021fc58fa101 /include
parentca2ef4a79f4e93d8b5eb9441f33e6cc9b0a6e39c (diff)
downloadupstream-8f89b1ab0fef81c85925c88e99a557e91e575aa3.tar.gz
upstream-8f89b1ab0fef81c85925c88e99a557e91e575aa3.tar.bz2
upstream-8f89b1ab0fef81c85925c88e99a557e91e575aa3.zip
image: add 'append-image' build command
Commit 7ce1d9ce09 ("build: artifacts add dependency for built images") now makes sure that sysupgrade and initramfs images are available at the stage that artifacts are created. Allow making use of that with a new build command 'append-image' to be used in artifacts. See the next commit for an example. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'include')
-rw-r--r--include/image-commands.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 684646e233..ec4f9624f5 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -27,6 +27,10 @@ define Build/append-kernel
dd if=$(IMAGE_KERNEL) >> $@
endef
+define Build/append-image
+ dd if=$(BIN_DIR)/$(IMG_PREFIX)$(if $(PROFILE_SANITIZED),-$(PROFILE_SANITIZED))-$(1) >> $@
+endef
+
compat_version=$(if $(DEVICE_COMPAT_VERSION),$(DEVICE_COMPAT_VERSION),1.0)
json_quote=$(subst ','\'',$(subst ",\",$(1)))
#")')