aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2019-08-18 09:56:45 -1000
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-06-30 22:12:39 +0200
commit8a0362c6992d2a432ecb79905531a6c7324fa6a8 (patch)
tree122442c6d1fb600cfd85429411fe815428d0cd1f /include
parent8293c8ed468e2d7c976e44a1343e52d35bdf1425 (diff)
downloadupstream-8a0362c6992d2a432ecb79905531a6c7324fa6a8.tar.gz
upstream-8a0362c6992d2a432ecb79905531a6c7324fa6a8.tar.bz2
upstream-8a0362c6992d2a432ecb79905531a6c7324fa6a8.zip
build: create JSON files containing image info
The JSON info files contain details about the created firmware images per device and are stored next to the created images. The JSON files are stored as "$(IMAGE_PREFIX).json" and contain some device/image meta data as well as a list of created firmware images. An example of openwrt-ramips-rt305x-aztech_hw550-3g.json { "id": "aztech_hw550-3g", "image_prefix": "openwrt-ramips-rt305x-aztech_hw550-3g", "images": [ { "name": "openwrt-ramips-rt305x-aztech_hw550-3g-squashfs-sysupgrade.bin", "sha256": "db2b34b0ec4a83d9bf612cf66fab0dc3722b191cb9bedf111e5627a4298baf20", "type": "sysupgrade" } ], "metadata_version": 1, "supported_devices": [ "aztech,hw550-3g", "hw550-3g" ], "target": "ramips/rt305x", "titles": [ { "model": "HW550-3G", "vendor": "Aztech" }, { "model": "ALL0239-3G", "vendor": "Allnet" } ], "version_commit": "r10920+123-0cc87b3bac", "version_number": "SNAPSHOT" } Signed-off-by: Paul Spooren <mail@aparcar.org> (backported from commit 881ed09ee6e23f6c224184bb7493253c4624fb9f) Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'include')
-rw-r--r--include/image.mk17
1 files changed, 16 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 1538d83df3..2eedb43753 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -524,7 +524,20 @@ define Device/Build/image
$(BIN_DIR)/$(call IMAGE_NAME,$(1),$(2)): $(KDIR)/tmp/$(call IMAGE_NAME,$(1),$(2))
cp $$^ $$@
-
+ $(if $(CONFIG_JSON_ADD_IMAGE_INFO), \
+ DEVICE_ID="$(DEVICE_NAME)" \
+ BIN_DIR="$(BIN_DIR)" \
+ IMAGE_NAME="$(IMAGE_NAME)" \
+ IMAGE_TYPE=$(word 1,$(subst ., ,$(2))) \
+ IMAGE_PREFIX="$(IMAGE_PREFIX)" \
+ DEVICE_TITLE="$(DEVICE_TITLE)" \
+ TARGET="$(BOARD)" \
+ SUBTARGET="$(SUBTARGET)" \
+ VERSION_NUMBER="$(VERSION_NUMBER)" \
+ VERSION_CODE="$(VERSION_CODE)" \
+ SUPPORTED_DEVICES="$(SUPPORTED_DEVICES)" \
+ $(TOPDIR)/scripts/json_add_image_info.py \
+ )
endef
define Device/Build/artifact
@@ -542,6 +555,8 @@ define Device/Build/artifact
endef
define Device/Build
+ $(shell rm -f $(BIN_DIR)/$(IMG_PREFIX)-$(1).json)
+
$(if $(CONFIG_TARGET_ROOTFS_INITRAMFS),$(call Device/Build/initramfs,$(1)))
$(call Device/Build/kernel,$(1))