aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorKarl Palsson <karlp@tweak.net.au>2021-05-17 00:38:03 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2021-05-23 15:11:38 +0200
commit81d0ddc806e1f088328ca29eb56db9285b2a4f7b (patch)
tree67a08a5b5ad7fe1112293129bbeb2338c697ef0a /include
parent080a0b74e39d159eecf69c468debec42f28bf4d8 (diff)
downloadupstream-81d0ddc806e1f088328ca29eb56db9285b2a4f7b.tar.gz
upstream-81d0ddc806e1f088328ca29eb56db9285b2a4f7b.tar.bz2
upstream-81d0ddc806e1f088328ca29eb56db9285b2a4f7b.zip
prereq-build: g++ formatting and consistency fixes
Remove \n that mangles output, and fix inconsistent version name check. Example before: Build dependency: Please install the GNU C++ Compiler (g++) 6 or later Build dependency: \nPlease reinstall the GNU C++ Compiler (4.8 or later) - it appears to be broken Build dependency: Please install ncurses. (Missing libncurses.so or ncurses.h) Signed-off-by: Karl Palsson <karlp@tweak.net.au>
Diffstat (limited to 'include')
-rw-r--r--include/prereq-build.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 8adf0d03dd..639d1ad0fa 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -31,7 +31,7 @@ $(eval $(call SetupHostCommand,gcc, \
gcc --version | grep -E 'Apple.(LLVM|clang)' ))
$(eval $(call TestHostCommand,working-gcc, \
- \nPlease reinstall the GNU C Compiler (6 or later) - \
+ Please reinstall the GNU C Compiler (6 or later) - \
it appears to be broken, \
echo 'int main(int argc, char **argv) { return 0; }' | \
gcc -x c -o $(TMP_DIR)/a.out -))
@@ -43,7 +43,7 @@ $(eval $(call SetupHostCommand,g++, \
g++ --version | grep -E 'Apple.(LLVM|clang)' ))
$(eval $(call TestHostCommand,working-g++, \
- \nPlease reinstall the GNU C++ Compiler (4.8 or later) - \
+ Please reinstall the GNU C++ Compiler (6 or later) - \
it appears to be broken, \
echo 'int main(int argc, char **argv) { return 0; }' | \
g++ -x c++ -o $(TMP_DIR)/a.out - -lstdc++ && \