aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2018-07-20 10:40:43 +0200
committerFelix Fietkau <nbd@nbd.name>2018-07-20 10:40:58 +0200
commit7c306ae640feb4d42b352175de27b034bd917938 (patch)
tree6e4824da51dc0496eb71ae2de074a5db28c7a52e /include
parente22cc57593127bc888c6b04587a3a2e8e43abe66 (diff)
downloadupstream-7c306ae640feb4d42b352175de27b034bd917938.tar.gz
upstream-7c306ae640feb4d42b352175de27b034bd917938.tar.bz2
upstream-7c306ae640feb4d42b352175de27b034bd917938.zip
build: fix compile error when a package includes itself in PROVIDES
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include')
-rw-r--r--include/package-ipkg.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 9e2717e788..c374faa647 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -190,7 +190,7 @@ $(_endef)
fi; \
done; $(Package/$(1)/extra_provides) \
) | sort -u > $(PKG_INFO_DIR)/$(1).provides
- $(if $(PROVIDES),@for pkg in $(PROVIDES); do cp $(PKG_INFO_DIR)/$(1).provides $(PKG_INFO_DIR)/$$$$pkg.provides; done)
+ $(if $(PROVIDES),@for pkg in $(filter-out $(1),$(PROVIDES)); do cp $(PKG_INFO_DIR)/$(1).provides $(PKG_INFO_DIR)/$$$$pkg.provides; done)
$(CheckDependencies)
$(RSTRIP) $$(IDIR_$(1))