aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2018-11-20 17:20:39 +0100
committerJo-Philipp Wich <jo@mein.io>2018-12-18 17:22:08 +0100
commit75d4465464e615d97ed07dac503d39c904770542 (patch)
treec6d6221315b13c59093b6f1b0907d7c66e74a805 /include
parent0f5b8a92b42d2c0c8e3dc025ef3be7ee2163f3c4 (diff)
downloadupstream-75d4465464e615d97ed07dac503d39c904770542.tar.gz
upstream-75d4465464e615d97ed07dac503d39c904770542.tar.bz2
upstream-75d4465464e615d97ed07dac503d39c904770542.zip
include/rootfs.mk: remove boot directory
Currently every file in boot directory is copied over target /boot on root file system and is usually inaccessible because appropriate boot file system is mounted on top of it. Therefore remove /boot, which in result will also save space on target root file system. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl> (backported from 31075313bf69fff3803b7c1da1e0ed7e5773d999)
Diffstat (limited to 'include')
-rw-r--r--include/rootfs.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/rootfs.mk b/include/rootfs.mk
index 76425c017a..dc8621dbae 100644
--- a/include/rootfs.mk
+++ b/include/rootfs.mk
@@ -90,6 +90,7 @@ define prepare_rootfs
rm -f $(1)/usr/lib/opkg/lists/*
rm -f $(1)/usr/lib/opkg/info/*.postinst*
rm -f $(1)/var/lock/*.lock
+ rm -rf $(1)/boot
$(call clean_ipkg,$(1))
$(call mklibs,$(1))
endef