aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2021-02-16 08:21:08 +0100
committerPetr Štetiar <ynezz@true.cz>2021-03-15 14:00:44 +0100
commit7379f8bd3e7ee0722faa6ec8b2969081fbdc1e07 (patch)
treefe476cd7b649d1921d3cf27938d995dccae257d7 /include
parentbb95be9265a9e3eb71c4f50b5f289a75683405d4 (diff)
downloadupstream-7379f8bd3e7ee0722faa6ec8b2969081fbdc1e07.tar.gz
upstream-7379f8bd3e7ee0722faa6ec8b2969081fbdc1e07.tar.bz2
upstream-7379f8bd3e7ee0722faa6ec8b2969081fbdc1e07.zip
build: prereq: drop support for Python 3.5
The final Python 3.5 release was 3.5.10 in September 2020 [0]. This release series is now End-of-Life (EOL). The only LTS distribution that still only ships Python 3.5 is Ubuntu 16.04, which will be EOL in April 2021 [1]. The meson build system bumped their python requirement to 3.6 for the 0.57.0 release. This patch ensures that OpenWrt can update meson while still relying on the host python. [0] https://www.python.org/dev/peps/pep-0478/#id4 [1] https://ubuntu.com/about/release-cycle [2] https://mesonbuild.com/Release-notes-for-0-57-0.html#minimum-required-python-version-updated-to-36 Signed-off-by: Andre Heider <a.heider@gmail.com> [python3.6+ in README.md] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'include')
-rw-r--r--include/prereq-build.mk10
1 files changed, 4 insertions, 6 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 32edc6e437..b2526a1ec1 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -141,21 +141,19 @@ $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
$(eval $(call CleanupPython2))
-$(eval $(call SetupHostCommand,python,Please install Python >= 3.5, \
+$(eval $(call SetupHostCommand,python,Please install Python >= 3.6, \
python3.9 -V 2>&1 | grep 'Python 3', \
python3.8 -V 2>&1 | grep 'Python 3', \
python3.7 -V 2>&1 | grep 'Python 3', \
python3.6 -V 2>&1 | grep 'Python 3', \
- python3.5 -V 2>&1 | grep 'Python 3', \
- python3 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?'))
+ python3 -V 2>&1 | grep -E 'Python 3\.[6-9]\.?'))
-$(eval $(call SetupHostCommand,python3,Please install Python >= 3.5, \
+$(eval $(call SetupHostCommand,python3,Please install Python >= 3.6, \
python3.9 -V 2>&1 | grep 'Python 3', \
python3.8 -V 2>&1 | grep 'Python 3', \
python3.7 -V 2>&1 | grep 'Python 3', \
python3.6 -V 2>&1 | grep 'Python 3', \
- python3.5 -V 2>&1 | grep 'Python 3', \
- python3 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?'))
+ python3 -V 2>&1 | grep -E 'Python 3\.[6-9]\.?'))
$(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
git --exec-path | xargs -I % -- grep -q -- --recursive %/git-submodule))