aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-12-16 17:32:10 +0100
committerFelix Fietkau <nbd@nbd.name>2016-12-16 22:39:22 +0100
commit720b99215da295a2e7b4acdef30b58bec6acedc2 (patch)
tree73ac1ea4ae91e5d6b2bfcfbc7bb71434d81be922 /include
parent4921760a4531bff87c3928a622a5c9e50b9f56d3 (diff)
downloadupstream-720b99215da295a2e7b4acdef30b58bec6acedc2.tar.gz
upstream-720b99215da295a2e7b4acdef30b58bec6acedc2.tar.bz2
upstream-720b99215da295a2e7b4acdef30b58bec6acedc2.zip
treewide: clean up download hashes
Replace *MD5SUM with *HASH, replace MD5 hashes with SHA256 Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include')
-rw-r--r--include/kernel-build.mk2
-rw-r--r--include/kernel-version.mk10
2 files changed, 6 insertions, 6 deletions
diff --git a/include/kernel-build.mk b/include/kernel-build.mk
index 062c458ab7..2bf47b17e4 100644
--- a/include/kernel-build.mk
+++ b/include/kernel-build.mk
@@ -43,7 +43,7 @@ endef
define Download/kernel
URL:=$(LINUX_SITE)
FILE:=$(LINUX_SOURCE)
- MD5SUM:=$(LINUX_KERNEL_MD5SUM)
+ HASH:=$(LINUX_KERNEL_HASH)
endef
KERNEL_GIT_OPTS:=
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index eeb8195ff0..32752a2474 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -6,9 +6,9 @@ LINUX_VERSION-3.18 = .43
LINUX_VERSION-4.1 = .34
LINUX_VERSION-4.4 = .38
-LINUX_KERNEL_MD5SUM-3.18.43 = b1faeb4a2e1e70ffe061bdbb3452840a
-LINUX_KERNEL_MD5SUM-4.1.34 = fba99f0f4765ebf01033e69518740a3c
-LINUX_KERNEL_MD5SUM-4.4.38 = 77ed9e650b65788a1f9f371ba87c2e50b5ba7624bc834ae38b036f7f592816a6
+LINUX_KERNEL_HASH-3.18.43 = 1236e8123a6ce537d5029232560966feed054ae31776fe8481dd7d18cdd5492c
+LINUX_KERNEL_HASH-4.1.34 = 412316b32b5c7a513ba3ab8e68fc443db4d9423f07b577473089def0ee7406af
+LINUX_KERNEL_HASH-4.4.38 = 77ed9e650b65788a1f9f371ba87c2e50b5ba7624bc834ae38b036f7f592816a6
ifdef KERNEL_PATCHVER
LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
@@ -21,5 +21,5 @@ KERNEL=$(call merge_version,$(wordlist 1,2,$(call split_version,$(KERNEL_BASE)))
KERNEL_PATCHVER ?= $(KERNEL)
# disable the md5sum check for unknown kernel versions
-LINUX_KERNEL_MD5SUM:=$(LINUX_KERNEL_MD5SUM-$(strip $(LINUX_VERSION)))
-LINUX_KERNEL_MD5SUM?=x
+LINUX_KERNEL_HASH:=$(LINUX_KERNEL_HASH-$(strip $(LINUX_VERSION)))
+LINUX_KERNEL_HASH?=x