aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-09-01 05:20:21 +0000
committerNicolas Thill <nico@openwrt.org>2007-09-01 05:20:21 +0000
commit6a8ab4c0beed0084a5fadb81eea98433c7d2c16b (patch)
tree892c1fad84308c7958d3d6266356535ab1faba30 /include
parent401d8ca98b1af6e1ab01f3490c8c6f32bc92e6e4 (diff)
downloadupstream-6a8ab4c0beed0084a5fadb81eea98433c7d2c16b.tar.gz
upstream-6a8ab4c0beed0084a5fadb81eea98433c7d2c16b.tar.bz2
upstream-6a8ab4c0beed0084a5fadb81eea98433c7d2c16b.zip
fix .dep_files exclusion in rdep calls
SVN-Revision: 8567
Diffstat (limited to 'include')
-rw-r--r--include/package.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/package.mk b/include/package.mk
index 0b33352941..254588e8a0 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -32,8 +32,8 @@ ifeq ($(DUMP)$(filter prereq clean refresh update,$(MAKECMDGOALS)),)
ifneq ($(if $(QUILT),,$(CONFIG_AUTOREBUILD)),)
define Build/Autoclean
$(PKG_BUILD_DIR)/.dep_files: $(STAMP_PREPARED)
- $(call rdep,${CURDIR} $(PKG_FILE_DEPEND),$(STAMP_PREPARED),$(PKG_BUILD_DIR)/.dep_files,-x "/.dep_*")
- $(if $(filter prepare,$(MAKECMDGOALS)),,$(call rdep,$(PKG_BUILD_DIR),$(STAMP_BUILT),,-x "/.dep_*" -x "*/ipkg*"))
+ $(call rdep,${CURDIR} $(PKG_FILE_DEPEND),$(STAMP_PREPARED),$(PKG_BUILD_DIR)/.dep_files,-x "*/.dep_*")
+ $(if $(filter prepare,$(MAKECMDGOALS)),,$(call rdep,$(PKG_BUILD_DIR),$(STAMP_BUILT),,-x "*/.dep_*" -x "*/ipkg*"))
endef
endif
endif