aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-23 13:40:15 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-23 13:49:45 +0100
commit6699f58fdbfd74cd3206bd1bc3311e395204ba30 (patch)
tree8cbeaf98dddcb65dbeeb545bc3185614ed2c46bb /include
parent1590b0fab077e046450bc3625b921319a281a66c (diff)
downloadupstream-6699f58fdbfd74cd3206bd1bc3311e395204ba30.tar.gz
upstream-6699f58fdbfd74cd3206bd1bc3311e395204ba30.tar.bz2
upstream-6699f58fdbfd74cd3206bd1bc3311e395204ba30.zip
build: use if-then to avoid non-zero return codes in bin/ packaging code
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include')
-rw-r--r--include/package-bin.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/package-bin.mk b/include/package-bin.mk
index 68f5831340..4ae049af54 100644
--- a/include/package-bin.mk
+++ b/include/package-bin.mk
@@ -29,10 +29,10 @@ ifeq ($(DUMP),)
install-bin-$(1): $(PKG_BUILD_DIR)/.pkgdir/$(1).installed
rm -rf $(BIN_DIR)/$(1)
-rmdir $(PKG_BUILD_DIR)/.pkgdir/$(1) >/dev/null 2>/dev/null
- [ -d $(PKG_BUILD_DIR)/.pkgdir/$(1) ] && { \
+ if [ -d $(PKG_BUILD_DIR)/.pkgdir/$(1) ]; then \
$(INSTALL_DIR) $(BIN_DIR)/$(1) && \
$(CP) $(PKG_BUILD_DIR)/.pkgdir/$(1)/. $(BIN_DIR)/$(1)/; \
- }
+ fi
clean-$(1):
rm -rf $(BIN_DIR)/$(1)