aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-06-10 20:27:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-06-10 20:27:37 +0000
commit63c8fa0bbb119d27bfcee448f7ef3d68e9b900ad (patch)
tree7d5cc10fab9247182ace803a3e6bfe5158b598da /include
parent184d669fb3f3dc845c0b7d7fcefdadcddc142462 (diff)
downloadupstream-63c8fa0bbb119d27bfcee448f7ef3d68e9b900ad.tar.gz
upstream-63c8fa0bbb119d27bfcee448f7ef3d68e9b900ad.tar.bz2
upstream-63c8fa0bbb119d27bfcee448f7ef3d68e9b900ad.zip
build: add a dependency on libc to all non-kernel packages
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32171 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/package-defaults.mk6
-rw-r--r--include/package-dumpinfo.mk2
2 files changed, 7 insertions, 1 deletions
diff --git a/include/package-defaults.mk b/include/package-defaults.mk
index 75442925f1..c3496767cf 100644
--- a/include/package-defaults.mk
+++ b/include/package-defaults.mk
@@ -5,6 +5,12 @@
# See /LICENSE for more information.
#
+ifneq ($(PKG_NAME),toolchain)
+ PKG_FIXUP_DEPENDS = $(if $(filter kmod-%,$(1)),$(2),+libc $(filter-out +libc,$(2)))
+else
+ PKG_FIXUP_DEPENDS = $(2)
+endif
+
define Package/Default
CONFIGFILE:=
SECTION:=opt
diff --git a/include/package-dumpinfo.mk b/include/package-dumpinfo.mk
index a297f2336e..2bf78c3f18 100644
--- a/include/package-dumpinfo.mk
+++ b/include/package-dumpinfo.mk
@@ -30,7 +30,7 @@ $(if $(MENU),Menu: $(MENU)
)$(if $(DEFAULT),Default: $(DEFAULT)
)$(if $(findstring $(PREREQ_CHECK),1),Prereq-Check: 1
)Version: $(VERSION)
-Depends: $(DEPENDS)
+Depends: $(call PKG_FIXUP_DEPENDS,$(1),$(DEPENDS))
Menu-Depends: $(MDEPENDS)
Provides: $(PROVIDES)
$(if $(VARIANT),Build-Variant: $(VARIANT)