aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2023-05-23 14:17:47 +0200
committerPetr Štetiar <ynezz@true.cz>2023-05-23 21:41:39 +0200
commit56ffc5a86676b105e806734e722f581f8ccb2a2a (patch)
tree8c25260009f8de69a53573ba4f84e7705d684bc6 /include
parent7f0db09513c88e9c68f121d33cf56754e967b349 (diff)
downloadupstream-56ffc5a86676b105e806734e722f581f8ccb2a2a.tar.gz
upstream-56ffc5a86676b105e806734e722f581f8ccb2a2a.tar.bz2
upstream-56ffc5a86676b105e806734e722f581f8ccb2a2a.zip
prereq: SetupHostCommand: fix wrong check result
Tony has reported, that CI tools job is failing for him in macOS container due to prereq check failure for GNU `install` utility. Michael diagnosed it and from his traces it was clear, that the issue is caused by a wrong return value in the success check case, so lets fix it accordingly. Fixes: f75204036ccc ("prereq-build: allow host command symlinks to update") Reported-by: Tony Ambardar <itugrok@yahoo.com> Diagnosed-by: Michael Pratt <mcpratt@pm.me> Signed-off-by: Petr Štetiar <ynezz@true.cz> (cherry picked from commit 7855378fcd7ed7cb0a223238a99bac0b8e46c380)
Diffstat (limited to 'include')
-rw-r--r--include/prereq.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/prereq.mk b/include/prereq.mk
index 5646b24efa..74c3914d06 100644
--- a/include/prereq.mk
+++ b/include/prereq.mk
@@ -113,7 +113,7 @@ define SetupHostCommand
;; \
esac; \
ln -sf "$$$$$$$$bin" "$(STAGING_DIR_HOST)/bin/$(strip $(1))"; \
- exit 1; \
+ exit 0; \
fi; \
fi; \
done; \