aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2021-02-24 21:38:15 +0100
committerDavid Bauer <mail@david-bauer.net>2021-02-24 22:28:45 +0100
commit512229ce4967814a09ce202855e6b632d2e97a3c (patch)
tree51a2af7c8190eace50bbcba6ec4a23cafe9e8739 /include
parenta7ff66e2d29e439d7e53bc5102b4662f292d7642 (diff)
downloadupstream-512229ce4967814a09ce202855e6b632d2e97a3c.tar.gz
upstream-512229ce4967814a09ce202855e6b632d2e97a3c.tar.bz2
upstream-512229ce4967814a09ce202855e6b632d2e97a3c.zip
build: avoid generating JSON info on missing image
Previously, build would fail for targets containing devices with not initramfs image (such as mpc85xx-p1010). Only generate the JSON image info for the initramfs image when we have one to avoid breaking the builds. Fixes commit d3140d052964 ("build/json: generate json file for initramfs") Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'include')
-rw-r--r--include/image.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/image.mk b/include/image.mk
index e602f2f4e9..8cfd2155f3 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -472,8 +472,8 @@ endef
ifndef IB
define Device/Build/initramfs
$(call Device/Export,$(KDIR)/tmp/$$(KERNEL_INITRAMFS_IMAGE),$(1))
- $$(_TARGET): $$(if $$(KERNEL_INITRAMFS),$(BIN_DIR)/$$(KERNEL_INITRAMFS_IMAGE)) \
- $$(if $$(CONFIG_JSON_OVERVIEW_IMAGE_INFO), $(BUILD_DIR)/json_info_files/$$(KERNEL_INITRAMFS_IMAGE).json,)
+ $$(_TARGET): $$(if $$(KERNEL_INITRAMFS),$(BIN_DIR)/$$(KERNEL_INITRAMFS_IMAGE) \
+ $$(if $$(CONFIG_JSON_OVERVIEW_IMAGE_INFO), $(BUILD_DIR)/json_info_files/$$(KERNEL_INITRAMFS_IMAGE).json,))
$(KDIR)/$$(KERNEL_INITRAMFS_NAME):: image_prepare
$(BIN_DIR)/$$(KERNEL_INITRAMFS_IMAGE): $(KDIR)/tmp/$$(KERNEL_INITRAMFS_IMAGE)