aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-08-24 12:10:14 +0000
committerNicolas Thill <nico@openwrt.org>2007-08-24 12:10:14 +0000
commit4b23cac27b45b5eca9dddb790c9127e737684fd9 (patch)
tree3e3845929706faeecc1c946187192abeabab3bdc /include
parente9fba2c56b6252c43693d627c90272bc748e9c30 (diff)
downloadupstream-4b23cac27b45b5eca9dddb790c9127e737684fd9.tar.gz
upstream-4b23cac27b45b5eca9dddb790c9127e737684fd9.tar.bz2
upstream-4b23cac27b45b5eca9dddb790c9127e737684fd9.zip
replace xargs commands with $(XARGS)
SVN-Revision: 8478
Diffstat (limited to 'include')
-rw-r--r--include/package.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/package.mk b/include/package.mk
index c928c310dd..1e18f8cd81 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -106,13 +106,13 @@ endef
# prevent libtool from setting rpath when linking
define libtool_disable_rpath
- find $(PKG_BUILD_DIR) -name 'libtool' | xargs \
+ find $(PKG_BUILD_DIR) -name 'libtool' | $(XARGS) \
$(SED) 's,^hardcode_libdir_flag_spec=.*,hardcode_libdir_flag_spec=" -D__LIBTOOL_IS_A_FOOL__ ",g'
endef
# prevent libtool from linking against host development libraries
define libtool_fixup_libdir
- find $(PKG_BUILD_DIR) -name '*.la' | xargs \
+ find $(PKG_BUILD_DIR) -name '*.la' | $(XARGS) \
$(SED) "s,^libdir='/usr/lib',libdir='$(strip $(1))/usr/lib',g"
endef