aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-05-10 11:46:50 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-05-10 11:46:50 +0000
commit2be2604a19f2c988371bdcedfb179cca76da0287 (patch)
tree2298d2404674b8e9c243dc2c842b232a5e0698d0 /include
parenta37814faa7689fd0c8ddf9000bb9556888ea2d63 (diff)
downloadupstream-2be2604a19f2c988371bdcedfb179cca76da0287.tar.gz
upstream-2be2604a19f2c988371bdcedfb179cca76da0287.tar.bz2
upstream-2be2604a19f2c988371bdcedfb179cca76da0287.zip
include: make dtb argument optional in MkFIT
As mkits.sh makes the -d argument optional, we'll make this same argument optional in the MkFIT function as well. With this change, MkFIT can be used both to generate FIT images with DT, and without DT. Signed-off-by: Mathieu Olivari <mathieu@qca.qualcomm.com> SVN-Revision: 45660
Diffstat (limited to 'include')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 788d593f94..a6237ff2e2 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -121,7 +121,7 @@ endef
define Image/BuildKernel/MkFIT
$(TOPDIR)/scripts/mkits.sh \
- -D $(1) -o $(KDIR)/fit-$(1).its -k $(2) -d $(3) -C $(4) -a $(5) -e $(6) \
+ -D $(1) -o $(KDIR)/fit-$(1).its -k $(2) $(if $(3),-d $(3)) -C $(4) -a $(5) -e $(6) \
-A $(ARCH) -v $(LINUX_VERSION)
PATH=$(LINUX_DIR)/scripts/dtc:$(PATH) mkimage -f $(KDIR)/fit-$(1).its $(KDIR)/fit-$(1)$(7).itb
endef